Not able to share with family

Hi all,

Looking for help, I’ve just installed the system and all is working well but when I tried to share with my wife I get the “waiting” message but she hasn’t got any notification to accept. The email arrives ok and she followed the link to install the app.

We have tried resending and uninstalled the app from her phone and reinstalled.

Any other tips? This is a make or break feature for us.


Same! Very frustrating

1 Like

Did you contact customer service?

Did she sign into the app using the email address you sent the permission request to? She has to have her own account using that email in order for it to work.

1 Like

We are in the same situation and it’s very frustrating due to this is the big reason why we bought it.

Any help?

1 Like

Neither here. Tried several times also changing country in both profile settings and nothing… we need a solution soon

Ran into this issue aswell. Was able to fix it.

I might be wrong but, it seems that the the email determines locale of the application or account. (email server location) My wife had the version v2.2.3_763 (EU) and I had version v2.2.3_763 (US). You can check this by going in the menu in the Eufy Security app and clicking about.

My wife used a email address with a custom domain, hosted in the Netherlands, I just simply used my gmail account. Which in turn gave us different versions of the app. I solved it by creating a account that uses the same domain as my wife’s email address. After that she received notification when I sent the invite.

Make sure you and the people you want to share it with have the same version of the app (EU/US). If this is the case, make sure you have the same email domains.

1 Like

This has been the salvation we needed!
For us, the issue was that my dad had an EU version of the app on his phone, while I had the US version (due to me working mostly in English, so my phone language is in USA English).
Had to change my phone language to Dutch (EU) while installing the app, after that the connection could be made and I received the invitation in the app!
Changed my phone language back to USA English afterwards and app still works fine. The app is still the EU version on my phone.
We also tested the email domain. He uses gmail, I tried a gmail and a hotmail account to check, and both got the invitation in the app. So (at least) .com accounts seem to work.
It was solely the EU/US version of the app that did not connect for us.

I comfirm it’s the problem of location EU or US. Eufy customer service is so unhelpful that I have to search for the correction solutions. What to say?

I had the similar problem. I just contacted with the problem. They got back to me in a day and said they had reset something on the backend. I had to logout and then reinvite. This time it prompted to accept invite on the other account.


Yes just to follow up. With a day or 2 of back and forth with customers services they did something in the background to fix for my wife and we both now have access.