Eufy Family & Guest sharing problem

For all of you who are having issues with adding family members, when you send the invite email to them…

  1. make sure it is there email separate from the main account email
  2. They have to create their own eufy security account using their own email address
  3. Once they create their own eufy security account they need to log in with their account and if they already have an account have them log out and then log back in after the invite was sent.

This is what they will see after the invite was sent and they either log in or log out and back in in order to see It. The pop up asking to accept the invite

It is not that hard to add family members provided you follow the steps in the email.

If they do no have an account they will see this email informing then to download the app and register their account.

However, if they do have an account they will get this email. If refreshing doesn’t bring up the invite, logging out and back in will.


Thanks Tank that’s what I was trying to say. Your deeper instruction is well done… Be safe all :v:t3:

You say it’s not hard but the feature doesn’t seem to be working. I’ve lost count of the amount of invites I’ve sent to my partner and how many times we’ve uninstalled / installed / logged in / logged out / refreshed the app homepage


I have the same issue. The only email I get asks to download the app, so the system does not recognize I already have an account. I tried all these instructions, logged out, deleted the app, reinstalled and I even tried creating a brand new account with a different email. Nothing, no email telling me to go to the app to accept and no pop up in the app. Very annoying.


same here, no accept button when logging into the app with the new account.
although I truly believe @Tank description is how it is suppose to happen, it doesn’t.
Only the mail is received where I’m asked to download the app and register an account in the app.

So it seems eufy is not recognising my new account (yet?). I don’t get the mail asking to go to my app, click the accept button or refresh the app homepage. I only get the mail with the download appstore / google play buttons

Might be a possible fix. Reply I made on another topic.

1 Like

Thanks for this, will check on it :relaxed:

Hi Marc,
I seem to be in the same situation: my partner has EU, I have US.
How did you manage to fix this / work around it?

Thanks for the instructions. Unfortunately, it doesn’t work for me. I am the Admin, I share with my wife, she has created an account. She has signed in (out, back in, multiple times) … but there is no invite to accept. All she sees is the “Add Device” screen. I have deleted her invitation and created a new one, repeated the process, but still not working. Basically, she has no invitation to accept.

@AnkerSupport - please can you fix this? There are multiple threads and dozens of users facing this issue.

We are having the same issue here. Already tried creating different accounts with different email addresses and still nothing. This is so frustrating. Very disappointed with this product.

I have the same. Sounds like a persistent issue and no one is taking care of it. Now going to Amazon to write a perfect review about it.

Hello isabel11
I has issue trying to invite my relatives as admin too. The reason is the account that they are created is not in the same region as your acc. Try to login with your relatives acc and click on the About option u will see the location of their acc either US or EU. Always make sure your acc and the person you want access to your cams have the same location.

I fix this issues by emailing the tech team at I gave the tech support serial of one of my cam and tell him to set location of all of my relatives “app logins” (include gmails and hotmails acc) to US (or the location same as your acc).

Email the tech support. In the email give them the serial number of one of your product and subject of the email is Move account app location so they know what they are dealing with, then tell them to move the app account of the person u want to get access to US or EU same as the location of your acc in app.

1 Like

I comfirm it’s the problem of location EU or US. Eufy customer service is so unhelpful that I have to search for the correction solution.

I have the issue as well, used to be able to share by sending invitation to new account. Now it will not work anymore and only after finding this in the forum confirms that Eufy has an issue with their accounts.

Both my accounts are NL accounts and i am using the same app on the same phone to check.
Wish they would fix it as i am unable to work with this now.


Same issue as the others here.
The invite does not work.
The invitee should not need to add the device. When my wife added the device, i (the admin) lost access to the camera. :frowning:

Needs to be sorted.

Same issue. I just install doorbell today and created admin account with my email address on my iphone and everything works fine.
And I create guest account with my wifes andiod phone and assigned to guest account. gust email can receive the invitaiton email but nothing poped at adriod phone at all.
I am in Australia. Hope Eufy can fix this soon.

I have the same problem eufysecurity …in the other app eufyhome for robovacum was very easy to invite guest… very annoying!!

Hello all, I had the same issue where the account admin kept sending me invites but I would never receive the accept notification. The solution was to use two emails with the same region code on the end. For example .ca and .ca. The admin had a .ca account and was sending to my account. Once I created an email with a .ca account it worked and I was able to get the accept notification.

I think the latest version of the app will let you set a region when you log in the first time. Just make sure that all your invitees and the main account are set up in the same region. Believe that’s been the root of the issue of not receiving the confirmation popup after getting an invitation.