Intruder recorded, SD card needs formatting - help!

The Eufy 2k indoor cam has recorded an intruder and I wanted to download the videos from the SD card to my phone via the Eufy App.
I could download 1 video and the next video download got stuck at 19%. Few moments later the app shows “video deleted”. The next moment the Eufy App claims the SD card needs to be formatted. That means all recordings will be lost in the process.
The contents on the SD card are encrypted, so I can’t just copy videos with an SD card reader to a computer.
Is there any way to restore the SD card content without formatting?
This is a grave error Eufy!

1 Like

Have you tried removing the SD card and putting it back in? Except I don’t know if that will cause it to do an auto format on the SD card…

If it’s still requesting to be formatted, yes as you stated you will lose all recordings.

There is a repair you can do on the SD card via windows PC though it may or may not work.

Can SD card be repaired?

The CHKDSK command will find SD card file system corruption errors and remove bad sectors. This is also the most applicable way to repair a corrupted SD card without formatting. Running chkdsk can hopefully fix the corrupted file system, however, it can also result in total data loss.

How to use CHKDSK to repair corrupted SD card?

  1. Connect the sd card to your computer.
  2. Run Command Prompt as administrator.
  3. Type in the following command: chkdsk X: /f(replace X with the drive letter of the SD card you want to fix).
  4. Wait for the process to finish.

Try some internet searches on repairing it.
Good luck.

Removing the sd card does not lead to it showing up later on in the camera or Eufy App, already tried. Also did reboot the camera several times. No luck.
The sd card reader on Windows PC shows that the sd card is in a file format that can’t be accessed directly with Windows Explorer. I did not try to run chkdsk.

I am sorry for the issue and hope that you can fix it but I think it got corrupted as well.

I would try the chkdsk to see if that may can help fix it via the app or even from the pc. The worse case is you lost the files. You may want to tinker to see if it is everything or just a few items…

My only other question is the SD card a new one or one that you already had around and had used previously in other devices. I would try a newer card instead of just a reformat of the same card.

I bought the Samsung SD card for the Eufy camera.
I presume there was some software issue rather then a problem with the SD card itself.

Dang it, the app showed several video thumbnails with the intruder.
At least I could save one short video from the camera where you can see the face.
I’ll look for a video recorder, I won’'t trust this current recording system anymore.

1 Like

Having issues with new recorded videos, again…

I had a problem to run chkdsk on the sd card: “CHKDSK Is Not Available for RAW Drives”.

Likely everything on the sd card was lost anyway, so I did format the sd card on PC and then run chkdsk again. Result: no bad sectors or errors found.

I used the sd card in the Eufy camera again to record new videos, at least one had an error.
90% of the video plays back in the app, but the last few seconds are simply skipped.
Trying to download the video goes to ~90%, then the app gets stuck and just turns into a white screen.
This time the app does not force to format the sd card, but there is an obvious problem somewhere.

Firmware is, while the newest version is
I’ll try to update to the latest version and see if this eliminates the problem.

I would also try installing a new SD card to see if it happens with that one also…

1 Like

You need to use High Endurance SD cards. If you don’t they become corrupted after some time. The cheaper card won’t last very many cycles before they are toast.

Samsung EVO (+Sony) are among the most reliable SD cards.
The camera did not continuously record, but only trigger recording on events. This heavily reduces re-write cycles and extends the life span of the SD card.

I can change the SD card, but rather expect there is some software issue corrupting the recording process.

With the latest firmware update the recordings are saved properly so far.
I’ll continue to run this system while I’ll look out for an option to save the RSTP stream on an external recorer: any product suggestions here? P.S.: Eufy indoor pan & tilt is wireless / a WiFi camera. Thanks

I had a poor quality unit C24. One finger had cold solder. Leg could lift when cold.

Update over a week of using the latest firmware: no issues with recording to the same SD card so far.

1 Like