Can’t login in the app

I’m trying to add my girl in the app, she has made an account, but she can’t login on the app, the message appears “service unavailable (503)” now what?? I don’t know it anymore…


same issue here. a 503 error typically means server side issue.

Eufy? help?

1 Like

Confirmed here as well. 503 error on the app, server can’t be reached.

Sites at are unreachable as well.

1 Like

Well this happens in the app of my girl. Not on the website, there she can login without any problem… @eufy

The website I showed is actually where the login is processed by the eufyCam2.

i get “unable to connect to the application server”. the eufy servers must be down. so much for having local control of your security system


Same here, error 503

1 Like

Same 503 errors on my end adding or removing cameras. I was on the phone with support a few hours ago and he mentioned their order system went down which is probably why the support went down since they probably are getting an influx of calls and can’t do any RMAs.

All of that said Eufy needs a status page because now they have a system wide issue.


So it sounds like a problem on the serverside and nothing I/we can do about it for now?

Yes, having same issue when trying to add to remove a 2c camera to Homebase 2. Thought it was a local device issue, but apparently not… :crossed_fingers: let’s hope they figure this out soon.

Yes, a status page would be great. :+1:


Agree, I’m having the same issue here, unable to connect. We need a status page and a way to locally connect to the cameras when there is an issue, at least if we are in the she Wi-Fi this should not be a problem.


Yes, the fact that there is an external dependency like this is concerning.

1 Like

Has anyone spoken to Eufy to try and get actual answers from them directly?

Im in the UK and still able to view doorbell and my 2c live on WiFi & 4G mobile network.

What’s your location?

Call center is not accepting calls. Not good.

1 Like

Same here and it goes in and out. Shouldn’t have to connect this way to view our clips. Seems to shady and not secure


Came here for the first time just to see if the issue is widespread. It looks like it is.
I was able to do a live feed but not retrieve my video clips (local uSD storage, Indoor Cam 2K) - was getting a “Unable to connect to the application server.” message.
I logged out of the app, but couldn’t log back in, so it was worst lol.

edit 1: - Just now, 1230pm PST - i’m able to login and retrieve clips.
edit 2" - 12:34pm PST - getting the ‘application server’ message again.

1 Like

No issue logging in. I have an issue viewing my events on the app. Says I have no internet but I do… so I can’t launch live view or view events. I tried with cellular connection and WiFi.

1 Like

I am not able to remove a camera and still get a 503 error when I try.