Why is the Eufy app freezing and disabling my iPhone (11 Pro Max)?

Why is this happening? I clicked the Eufy app and instead of the app opening it has been frozen with the blue screen that says “Eufy Security” disabling my iPhone for over an hour now. The frozen screen does not allow me to close the app or view anything else with the phone unlocked. I can receive notifications and view them but not reply. The force shutdown/restart is also being disabled. When using the force shutdown/restart commands it activates the SOS system and 911 dispatch calls. This is ridiculous and absurd.


This is just happened to me today, worse time too as on holiday and miles away from my supposingly secure home, my iPhone 11 has frozen up and can not use it. Only the EUFY security logo on a blue screen, so tried reset but Rung 111 and had to apologise.


Has this been fixed, and how did you fix it please, no help from EUFY at all so any suggestions please as my home is insecure and I’m miles away.

The same thing happened to me last night and unable to unlock. Hoping that when battery runs out that will autocorrect? Nothing is working to unlock. Not happy

1 Like

This just happened on my iPhone 8 S Plus. It just all the sudden had the Eufy blue screen and nothing would work, couldn’t even turn it off. I had my computer handy so I found the reset instructions on apple support page here: https://support.apple.com/en-us/HT201412, and the instructions for “If your screen is black or frozen” on how to force reset your phone worked for me. It took a minute or two to finish rebooting but seems to be working again now.


Exact same thing happened to my iPhone XR today. I also had to apologize to 911 dispatch and to my emergency contact. I could not power off or reset. Every attempt, same results. I had access to the control panel via a shortcut and luckily was able toggle airplane mode. Got on my PC and chatted Eufy Support. I said the app was acting like a virus. He said they were aware of the app behavior, but blamed it on Apple iOS. Recommended to reinstall app if I could the restart the phone. Took it to the Geek Squad, they were able to do a forced restart and uninstall the Eufy app. Big ordeal. Lost a little more faith in Eufy products. Currently have the wired video doorbell and indoor cam.

1 Like

On my less-than-a-week-old (new) iPad 5 Mini, I had experienced a software freeze but only from doing a full screen view of a live feed. I updated my iOS to 14.7.1, but the same event occurred. In both before and after updating iOS, I had to hold down the power and volume-down buttons until it either went to a black screen or rebooted.

I’m enjoying the Eufy experience otherwise & suggest that you add an outdoor loudspeaker as an option for the siren/vocal interaction of the security spotlight.

Spoke to Verizon. All you have to do is;
1- press and release volume up as quick as possible
2- press and release volume down as quick as possible
3- press and hold shut off for 45 seconds
These steps turned off the phone and reset once I turned it on again.
It worked for me!


The situation seems severe. You can force restart your iPhone by pressing the Home and Power buttons together. If no use, I guess you can use iTunes to restore your iPhone. But this is riskier. And the final tool you can use is TunesKit iOS System Recovery which can turn your iPhone back to normal.

This happened to me earlier. I tried opening the eufy app, and it froze my iPhone 11. I could only access the lock screen, and it wouldn’t give me the Slide to Power off (shutdown) prompt.

Used the method Cwj8 described - “Press and quickly release the volume up button, press and quickly release the volume down button, then press and hold the side button.” I knew it was something like that, but my phone was frozen and couldn’t look it up lol.

edit: Also didn’t help that I came from an iPhone 7 which increased my confusion about the force restart method.

1 Like

this just happened to me. I could not stop it from calling 911 or sending strange emergency welfare checks to my medical contacts. I struggled getting my phone to shut down. It finally worked with the method described below, to quickly press the up volume, down volume and hold the side button for 45 seconds until it powers off. After a minute I restarted my phone. This is very strange! It’s not cool at all.

1 Like

This is happening now with my iPhone XS. Reset instructions to quickly press the up volume, down volume and hold the side button for 45 seconds until it powers off did not work. Siri pops up but phone will not power off. I’ve never had this happen with any app.

1 Like

I tried the volume and hold the side button and not working

Same here. Love Eufy so much until this happened!

1 Like

This just happened to my daughter’s 12 ProMax and it did call 911. Took me about 10 minutes to restart the phone after I found this thread. Never had this happen to me on my Samsung Galaxy phone yet. This is not cool.

This just happened to my wife’s Iphone 12. A ‘siren’ sound went off. Eventually, we realized we could shut the phone down by holding the power button down after doing vol up, vol down quickly. You have to hold it down until you see the apple logo. How very strange.

Thanks for the advice. The quick press of each volume button then power button is what worked for me. Unfortunately called 911 also before finding this thread.

1 Like

Can’t believe this issue has been around for this long and it is still happening. Just had to separate iPhones completely freeze while using the Eufy app.

I recently had a similar issue tonight. The app opened and once in full screen mode I thought it was still working (sound from house was working as we have music playing for my pup when away) until I tried talking to try to settle my pup and realized nothing was happening. Tried to close my app but it locked the screen and would not allow me to restart my phone (iPhone 11) the usual way. Thankfully after random button pushing it did a restart and would work again. But def unsettling knowing my pup was upset then freaking out my phone was frozen on top of it all. Hopefully there’s a fix soon!!

thank you so much!!! it fixed it.