Unable to Connect to Homebase 2 - Eufy Updates

I’ve had the Eufy 2C system since May and have had several updates to the Homebase 2 using my Linksys Velop mesh system with no issues.
At the end of September Eufy pushed an update on my Homebase 2 which resulted in a update loop which never resolved using the mesh system. I was able to update the Homebase 2 by using one of my old ASUS routers, but unfortunately when I tried to switch back to my mesh system, the cameras live feed would work but the notifications and recording of live streams wouldn’t. I also can’t change settings in the Homebase 2 or add devices.
Eufy sent me another Homebase 2 and I was able to set it up and everything worked as it should. This week Eufy pushed a new update and it never correctly loaded so I’m back to a Homebase that only has live streaming again and no notifications or recordings on the Eufy app.

Have you tried connecting via an ethernet cable to get the update sorted? I have the HomeBase “pseudo 1” T8001 that I normally have it connect to my home network 2.4GHz wifi. If I plug in an ethernet cable it automatically “switches” to ethernet and then when I remove the ethernet cable it switches back to the configured 2.4GHz WiFi. Might be worthwhile connecting via ethernet and doing a reset or power off/on. If that doesn’t work, leave it connected via ethernet and getting Eufy support to “push” another update to the T8010.

Thanks for the reply.

Yes, that’s my standard setup is to have the Ethernet cable plugged in. I do have have the 2.4GHz set up in the Homebase 2 WiFi settings. Can the Homebase 2 get an update when it’s on WiFi and not using the Ethernet cable?
My setup is:
Spectrum E31T2V1 modem
Linksys Velop mesh system WHW03
D-Link DGS-2205 switch
Homebase 2 - 3 2C cameras - Wired doorbell
The wired doorbell has worked flawlessly ever since I bought it. The 3 2C cameras all show live video like they should. When I do a motion test the red light flashes when detecting motion. The only issue is when I try to adjust any settings on either the 2C cameras or the Homebase 2,itself I get the Unable to connect to Homebase -3 error message.

Sorry about the delay in responding.

Yes a home base firmware can be updated whilst connected via 2.4 GHz WiFi - the ethernet connection is only needed initially for initial configuration (probably just so the 2.4 GHz WiFi can be configured for your home networks 2.4 GHz network name and password).

With my HomeBase “pseudo 1” T8001, it automatically detects the ethernet cable being plugged in and switches to use that connection (removing the cable is detected and it switches to WiFi) .

The Eufy Security application uses Eufy’s authentication servers (“out in the internet somewhere”) to authenticate your login details for the application (or for a web browser connection). It then passes the “network address” details needed for the application/browser to connect with the home base.

Generally a " Unable to connect to Homebase -3 error message" means there is/has been an issue with the home base connection. I have seen this occasionally when I am using the application (on an Android). so I retry using the application and it works.

I found out that there must’ve been some kind of corrupted firmware on my velop mesh system. I tried two other stand alone routers and both allowed me to update my eufy firmwares, add cameras and get notifications and see recordings. I factory reset my mesh system but haven’t tried to add the Homebase 2 to it to try and see if it’s working now.

When the power source os disconnected from the home base the battery should take over but the home base drops out and then need to reinstall all cameras.
Why and how long should the homebaae battery last? ?