Unable to connect to HomeBase (-1)

I’ve seen a good number of reports here about this type of error, but I’m not sure what suggestions people have to resolve it.

I’m using the Android app v2.4.0_817 (EU), and HomeBase version as of January 2021.

From the app, I can request a live view from the doorbell camera, which works OK. I can also watch the recorded events stored on the HomeBase.

The connection error happens when I tap a “Person alert” notification on the phone. In the app, the Notification setting is switched to show the related history event. As I say, when I tap the notification on the phone’s home screen, I get a greyed-out camera view and the error message “Unable to connect to HomeBase (-1)”.

Does anyone have a solution for this, or know what that mysterious (-1) means?

1 Like

Update - I contacted Eufy Support about this. They have identified the problem, and the plan is that it will be fixed in the next app update.

Greetings from The Netherlands. Last week received a new Eufy update on my Android phone, got some new fancy icons as well as the error message " Unable to connect to homebase (-1) ". 1 Homebase 2 + 2 Eufy Cam Pro 2. All connected to WIFI and was working great before the update. Signal between all 90-100% and also wifi by ISP as well as through Ubitique AP’s is working 100%. Formatting the homebase, showing camera’s views recording etc. works great; problems occur when trying to remove a record or when you want to make some changes to the homebase, for example change the time notation from 12h to 24h. Tried to connect through 4G, wifi ISP as well as Ubitique AP’s at home. Same result. Powered down the homebase; started up again and the message was gone for a day. Now returning again.

Did you manage to get a solution as mine has just started giving me that error message?

1 Like

My 2k battery doorbell is doing the same. Eufy truly are useless. I had 3 months waiting for a fix for a previous issue with my system. Praying this fix doesn’t take that long. But not holding my breath. I have emailed customer support. I will head back with updates when I get any.

1 Like

My 2k doorbell does that too, but only does it when i get a alert, go to view it and the error comes up, i go to events and have to view it from there. From there i dont get error. But really annoying as it delays instant viewing , takes about few mins to do the workaround.

When can we expect a solution? The bell is practically useless as it is.

Apologies for delay in replying. I emailed eufy and they sent me a replacement doorbell with homebase. Was not expecting that to be honest but it solved my issue straight away and if Eufy read this then thanks again. :pray:

My Eufy security system and was hoping to tap into the collective wisdom here for some guidance. I’m using the Eufy Security app version 3.2.1 on my Android device, and my HomeBase firmware is currently at version The issue I’m facing is related to the live view feature. While I can access live thekidsactivites.com views from my cameras within the app without any problems, I encounter an error when trying to view the live stream on my web browser.