Unable to connect to doorbell via WLAN iOS 14 update

since I have updated my iPhone to iOS 14 I am unable to get a live stream from my doorbell while I am connected through WiFi. It works via mobile data. The app has all the rights it needs.
With an iOS 13 device everything works as expected. Has anyone else similar problems or even better has someone solved this issue?
Thanks in advance!

I have the same problem. Updated my iPad to iOS14, the live streaming stops working. The error message is: Unable to connect to video doorbell. Tried all I could think, no luck.

Very strange as I’m typing this on my iPad Pro with iOS14.0.1 after just checking the Live View from my doorbell camera which is working fine!
Just a thought, but does the Live View stop working if the Eufy servers are down. Maybe they were down when you were checking Live View?

I have updated a second device with iOS 14.0.1 and it is not able to connect to the doorbell via WiFi too. The iOS 13 device can connect with no issues. I’ve tried to reinstall the app, rebooted the doorbell and the Homebase. Nothing changed…

Can you please describe your network setup? Do you have modem/router combination, separate modem and router or a separate modem with a mesh system? Do you have the ISP provided modem or your own?
Do you have the wired or battery operated doorbell?

I have the wired doorbell running iOS 14.0.1 and it’s working as it should through my Spectrum provided router and my Velop mesh system connected via 2.4 GHz on WiFi.

I don’t think live view or any settings have anything to do with eufy servers. Only the cloud storage will be allocated to eufy owned server space, rest all the controls are with the user.
@AtomX Have you tried restarting your modem/router, iPhone and doorbell?

@Ice4, I’m confused with your answer. You say “ Only the cloud storage will be allocated to eufy owned server space, rest all the controls are with the user.”, but I was led to believe all storage was done locally on the Homebase2 and NOT stored on the server?
Or have I misunderstood?

Correct. :point_up:

If you chose to subscribe to cloud storage by paying monthly fee, obviously the videos have to be stored in some server space that eufy purchased. Mind you all these are supposed to be encrypted no matter where they are stored.

Thanks for your help. I have a Router/modem (FritzBox) combination provided by the isp. The doorbell is the battery one but i connected it to the wiring of my house.
The phones are connected through 2,4 or 5 GHz wlan, depending on the signal strength.
The wlan devices are allowed to communicate among themselves. In the meantime I have restated every device which is involved in this scenario- nothing changed. The iOS 13 device is working fine while both iOS 14.0.1 devices are still unable to connect to the doorbell while they are connected to the local wlan.

I also noticed that the eufy app does not manage local network access permissions which were introduced in iOS 14. Even a new app installation could not solve the problem.

Still confused…

I’m using iOS 14 beta on my phone and iOS 14 on the other phone. Both have no issues connecting to doorbell on WiFi
I can’t tell if it’s the doorbell causing issue, you must restart modem/router to see if that resolves

I agree with this.

Can you restart the devices in this order?
1st power off all devices (including turning off the video camera and later restarting it) and wait two minutes.

  1. Start the modem/router first and make sure to wait until it’s connected to the internet.
  2. Turn on the doorbell camera and restart it.
  3. Turn on the iPhone and start the Eufy app.
  4. Check the doorbell camera livestream status.
    Are both the doorbell camera and iPhone on the 2.4 GHz band?
    Do you have access to the modem/router to check on the firewall settings or can you do port forwarding?
    I’m using the ISP modem, but use my own router to be able to adjust the settings in the router.
1 Like

Finally found the issue. The FritzBox have had a filter rule which blocks IoT traffic… :crazy_face:
Thanks for all your efforts!


That’s great to know the cause of the issue. Thanks for letting us know @AtomX

1 Like

Glad it worked @AtomX thanks for sharing :grinning: