The mystery of charging the hardwired battery doorbell

Hi there

This is a long-winded message so thank you to anyone who reads the whole thing.

I have a Eufy dual video doorbell, battery version E340.

And the way it charges when hardwired is a mystery to me. So are the transformer requirements. I know this has come up before, but I’ve found it nearly impossible to understand what normal behaviour is.

I paid an electrician to wire it in. He installed a 12VAC transformer. Now before anyone says that it has to be at least 16VAC let me say a few things:

  1. When going through the app set-up for hardwiring the doorbell, it says that you need 8 to 24VAC. This is so the hardwiring can trickle charge the battery.

  2. It appears that the 16VAC requirement is for the wired only version of doorbells. However Eufy is inconsistent in this messaging. It also appears that to run the pre-recording feature of the battery video doorbell, 16VAC may be needed. I have this option turned off.

  3. In New Zealand, where I live, 12VAC is the standard transformer for doorbells. Installing a larger transformer would involve some alterations that I am unwilling to do unless I can be sure it will improve the doorbell function. The electrician who installed the doorbell told me that a 12VAC transformer is standard, and it is what their company uses for Ring doorbells.

When I first hardwired the doorbell, the little green plug icon came on. And it stayed on for a couple of months. Then it disappeared, and stopped charging even when the charge went down to < 75%. I thought it might be an electrical contact problem, so I RMA’ed it in after talking to Eufy and they sent me a replacement.

And the replacement worked great, for two weeks, now the little green plug icon has disappeared again. But I am suspicious that it is charging a little, because at some point the charge went up from 79% to 80%, even though the little green plug icon didn’t appear.

I’ve turned off motion detection, and package detection, so that the doorbell only activates when the button is pushed, and there is no unnecessary battery drainage, but the little plug icon does not appear.

I’ve uninstalled and reinstalled the doorbell, without improvement.

There’s no difference if I connect to it directly, or via Homebase.

My questions are:

  1. What is the actual transformer requirement for the battery doorbell, not the wired only version.

  2. Is there a weird software thing which manages the trickle charge, such that it doesn’t always show the green plug?

Thank you…

I just got the E340 myself last month and see the little green plug in the app. I’m pretty sure that my doorbell transformer is 16V though which I think is 20VAC, but I’m not in New Zealand. I previously had a Ring battery doorbell connected to the transformer for years without any problems. I imagine the E340 doorbell may require a bit more power than the Ring did since it has two cameras inside and not one camera, but you’d think that shouldn’t matter when it comes to trickle charging the battery. But I always get confused with volts (V), volt amps (VA), and volt alternating current (VAC) ratings when it comes to transformers.

Did you try removing the battery and charging it to full and putting it back in? Maybe there’s a firmware thing that disables wired charging if the battery level is too low.

I was able to turn on the 4 second pre-recording under the storage setting which performed a few seconds of an activation step to ensure the doorbell was getting enough power before it enabled the feature.

I wish that they would still show the battery level even when the doorbell is wired to a transformer because I hope they only maintain a 90% battery level charge like Ring doorbells do when it’s connected to wired power in order to help protect the battery and make its life last longer.

I solved the issue of not knowing what the state of charge was while hardwired by installing a switch on the transformer to interrupt the voltage to the doorbell. If I flip it off and wait a few minutes, it shows the actual charge percentage. Since the AC voltage is trickle charging the battery, this is the only way to know for sure.

Thanks for the replies.

Still I don’t know if 12VAC is enough to trickle charge the battery, and why for two separate units, they worked fine for a few weeks and now seem to have stopped charging.

By the way the lowest overnight temperature at the moment for us is 6 degrees celsius, but during the day we are at 16 degrees celsius.

Any further information is appreciated.

I am in a mind to return the doorbell and be done with it, as these charging issues and voltage requirements were never clear, and are not on any printed documentation with the doorbell itself. I can only find them, and inconsistent information at that, when searching through the website and going through the app.

sathwik

Only 50 tickets left

12 Vac should be enough voltage for your battery doorbell, as long as you have the required current. The wired doorbell needs 16-24 volts in order to work, since it doesn’t have a battery.

Normally, you need about 10-12 VA because of losses to keep you in the green with normal voltage.

Another variable is number of detections. Eufy bases their battery life specs on 10 detections a day and 20 seconds of recording for each detection. If you have more than 10 events and/or your recording time is longer, then you will deplete the battery faster and need more capacity in your transfomer to keep the battery charged.

The last factor is temperature. If your temps drop below 0C, then all charging will stop to protect the batteries. If your temps stay low for several days, you won’t replenish charge and you can damage the batteries.

Thanks for this reply. The problem doesn’t go away even if motion detection is turned off. The lowest the temperature reaches in Auckland in the depths of winter is not quite freezing, so I’m unlikely to have the temperature issue.

I had another thought - is it possible that the battery charging system is damaging itself by drawing too much current? my transformer while 12VAC can supply up to 70W. That means up to 5.8 amps of current. Is it possible that too much current is being drawn causing a problem?

No, if the charging system is operating properly it will only use what it needs ~ VA / amp current.

If you’re transformer puts out more VA than required there is no issue, on the other hand if you’re transformer puts out less than required, then the transformer will burn out overtime (due to it being underrated for its use) and doorbell will have charging issues and probably not function properly.

1 Like