System not reliable anymore: 1 of the cameras going down all the time

From time to time camera goes down, and when trying to access it I receive a message "Failed to request (-203).
Sometimes it starts to work again and other times I have another message “Unable to connect to homebase (-2)”

The system was working fine for some months and it looks like after an update this started to happens.

Please fix the problem as I’ve seen more people complaining of the same issue and it is very important to have a system that you can trust.


Have you tried unplugging the device and wait 30 seconds before plugging it in again?

Can you please describe your setup:

  1. Modem only or combo modem/router.
  2. If separate router, than what type, single or mesh.

I had my initial setup on a modem with a separate mesh system which had the same error as you described. I tried everything I could to fix the situation by updating to the latest firmware and removing and adding back the cameras which I couldn’t do on the mesh system but I could on a different older single router then putting the mesh system back in place as the main router. However, I couldn’t get the cameras to work right as there would be audio but no video on some cameras. The solution for me was to start from scratch and use a single router instead of the mesh system and it’s been working fine ever since. If you have a mesh system you might want to try and reset it back to factory settings and set it up again and then add the factory reset Eufy system cameras back to the reset mesh system. I didn’t try that but it should work. I hope your situation is resolved for you.

I have a Google mesh WiFi with a floodlight cam pro, which is permanently offline. Eufy sent me a replacement to try and resolve the issue but I’ve come to the conclusion the camera simply isn’t compatible with Google WiFi, as you can’t specify the network settings. I can do the initial setup and connect to a 2.4g network, but after a few hours it goes offline. Tried over and over, completely frustrated with it. Floodlight works, just no camera

Also, and this is completely on a whim for people suffering this issue. Have you tried using the ‘performance mode - (beta)’?

that can be found in the app. click on the 3 stripes - top left
my devices
working mode

Would be interested to know for better or worse if it makes a difference?

another thing some of you might try is to plug the homebase into a smart plug and have it cycle off then on your home base once a day. i find the setup much more reliable with daily reboots.

1 Like