Synology Surveillance Station

So I have a synology NAS, with Surveillance station installed.
Whilst I can briefly link my CAM 2c camera, after a minute or 2 it will loose connection for some reason.

Any thoughts?

I have followed the instructions on the EUFY app.


Hey @garethdjohn81, thanks for reaching out.

For the NAS feature, the Synology DS115j is the one that supported by the eufycam.

If the issue still persists. please send us your eufy account and Homebase serial number to

We will have the specialist team to look into this case for you.

1 Like

I have the 412+
The DS115j is quite an old model, so doesnt make sense why you wouldnt support newer models as well?
So problem still persists!


Also worth pointing out that Synology does not support EUFY cameras, looking on their site and talking to their technical support they dont support EUFY at akll.


Never get through with NAS,too complicated…

1 Like

Well I wouldnt mind, but as USB HDD support I doubt will be introduced anytime soon, I would like to have an option which other similar camers seem to be able to do.

1 Like

Actually, as long as you can install Surveillance Station on your Synology NAS, you can use it with the Eufy cameras. Just go to the camera settings on the Eufy app, scroll down to RTSP and follow the prompts. On Surveillance station you have to use [User Defined} and put in the address from the camera on the Eufy app.

Also, you will need to set (i.e, make it static) the Homebase 2 address on your router before you connect your camera. You should also set the Synology NAS address on your router before you connect your camera.

But most Synology NAS only have 2 free camera licenses. If you want to connect more than 2 cameras, you will have to buy additional camera licenses (they come in 1, 4, and 8 packs, ~$50 for a 1 pack).

1 Like

Also, the camera will lose connection all the time, but the NAS will still record any video the camera records.

Also, get the Windows application for Surveillance Station as it is a much nicer interface than using the browser.

1 Like

I setup my Eufy cameras to record video clips to my Synology DS418 which I know only records when there is motion. Though Surveillance station is not recording the whole video clip. I am only getting like 2 or 3 seconds of the motion recording. When I look on the UEfy app in the events section, I see that there was 15 seconds of that video recording. How come Surveillance Station is only getting like 3 seconds of the video?

Has anyone else run into that problem?


Using 2k indoor camer and Motion, but it may be similar. One thing i have noticed is when the camera was set to do RSTP dor motion detection the stream would only appear when motion was detected. When it wasn’t the stream would just show a grey box. You may need to set Surveillance Station to record all the time instead of with motion if it has that option. Perhaps it is having some kind of detection conflict.

On a side note the new indoor cameras can be set to record continuously, and that has been working pretty well with the 2k indoor cam to motion on a VM on my home server.

1 Like

I have the problem that I sometimes have different streams. I can see some streams in the app and cannot find them on Synology. Also motion detection does not work if I set certain ranges. Although I have defined the area around the front door, passing cars are also recorded. Sometimes 3 sec., Sometimes also 10 sec.

As the eufy cameras already record only when they detect motion i think you should set the NAS to record continuously. Otherwise the camera would only send the stream to the nas when they detect motion, and the nas would only record after confirming there is motion in the video…

How can you make sure that the Surveillance Station is set to “Continuous”?

I think I did this by disabling “event detection” on each of the cameras in surveillance station. But, having said that, it recorded longer videos and the length of the video shows about the same duration as Eufy app. But, the DS cam footage or the browser view freezes after 5-7 seconds (even though surveillance station says the recording is longer than that). Any ideas?

In 2021 Eufy is still not recognized by Synology’s Surveillance Station app. I tried working through every bit of documentation (3 years old!) and could not achieve a robust connection, even through RTSP. When I called Eufy for some guidance, I was told that Eufy is not supported by Synology, or by Onvif and that there were no plans to make that happen going forward. I immediately dumped my Eufy cameras on Craigslist and moved to camera brands that are certified by Synology and Onvif. There are just so many times I am willing to BANG my head on the wall in frustration. I settled on Reolink cameras with Onvif configuration. The Synology app works perfectly on my desktop with Windows 10.

I am having same issue. Did you get it resolved?

As of July 4, 2023, this is still an unresolved issue.