Solocam s40 not connecting to wifi

Anyone else having trouble connecting their S40 solocam to wifi? I have an Xfinity dual band modem.

1 Like

What’s the encryption type and what type are you using? 2.4 or 5ghz?

I am having the same issue. I have an Orbi mesh system

1 Like

I can’t connect my s40 cameras to wifi either.
I KNOW I am using 2.4 ghz band. I think the QR code that you scan with the camera is too big because the bottom of the code block is covered slightly by the “NEXT” button .

I had to turn my airplane mode on, then turn wifi on. It worked instantly. I reached out to tech support through the app.

Strange, flight mode did inreed fix the probleem with WiFi also. Nice fix but such a bug in a 200 euro camera. No note with the package, just go to the forum and find the fix, not great, not great at all.

I had no issue with connecting to my Orbi mesh system. It synced right up.

I have tried the airplane mode. I am using 2.4 Ghz on an apple router. This is beyond disappointing as I have a door bell camera, Eufy camera with the Solar attachment and they both work with no problems. This is the only Eufy product I have issues with connecting .

Having the same issue with the floodlight 2 pro. Tried everything from disabling all the network bands except 2.4ghz, and tried guess mode with 2.4ghz only. Also tried airplane mode with wifi on. Nothing work, I’m on the second unit, and this is beyond frustrating for me.

Did anyone get a solution for this?


I have the same problem of connecting the s40 camera to wifi. Where I am, it was cloudy for three days so then the s40 completely died. This was odd bc 1) it is brand new, sun unobstructed, and fully charged to 100% first out of the box. It only had two months of usage and 2) I thought lithium would last longer but that’s another problem for another time if it happens again.

Anyway, I charged it for 15 hours via original USB but it still showed “low battery” or “unable to connect”. I charged it with another USB for 24 hrs then I kept trying to reconnect to the app via pushing on SYNC until it beeped/flashing blue but it kept telling me it was low battery at 2% or sometimes I can’t even open the device’s setting at all.

My internet is ATT fiber dual 5 and 2.4GHz. So I kept charging it for days and the problem kept persisting of the device telling me “unable to connect” and “low battery”. I really thought the device was a lemon at this point! I couldn’t even remove the device from the app to restart it, “failure to connect to device”.

I remember my camera doorbell (not Eufy) also had a problem connecting to the wifi. So what I did this time is put my phone on airplane mode with wifi on but it still did NOT WORK. It still showed the same problem of “unable to connect” or “low battery”/

This time I put the phone on airplane mode but connected to wifi in another room, place the device next to my router/modem, went back to my phone and added the device again like it was the first time setting it up, and it WORKED. It also automatically removed the “old” device of the same MAC off my app. And the battery is 100%.

All in all, basically re-install it and see if it will help. Don’t bother trying to remove the device from the app first.

If you have a VPN on your phone or device - turn it off.
Connected instantly once I saw this tip.
Would have saved hours of stress if I had have realised this.