SoloCam S340 solar charging issue

Just got a SoloCam S340. Instead of using the small solar panel that came with it, I used my already mounted Eufy Solar Panel I was using for my old eufycam 2 pro setup. Only difference was the connections to the old solar panel is mini usb while the solar that came with the S340 are USB-C, so I ended up just getting a mini usb to usb-c adapter so I could plug the old solar pane; into the new camera.

On a normal very sunny day like today, if I go into the power manager, have the power source set to solar panel, it doesn’t seem to be charging as the battery dropped to 88%. However, if I change the power source to “Battery” the camera will start charging without issue with the solar panel connected.

Anybody have any idea as to why it won’t charge when set to solar panel, but it will charge fine if I change the setting to “Battery”?

I don’t have that camera, but I would try to verify that your solar panel is actually charging the battery and it’s not the built-in solar panel on the cam when you have the power source on Battery.

You can do that by covering the built-in solar panel so sunlight doesn’t shine on it, then check the app to see if it is charging via your solar panel.

Also it could be that there is some type of monitoring / charging circuitry when you have the power source set to Solar… like when the battery percentage drops to a certain threshold it will begin charging. I don’t know?

Camera firmware up to date?

I’m having the same issue with my SoloCam E40. Worked perfectly for quite awhile with the eufycam solar panel I purchased with the camera. Always maintained a 100% charge. Then Eufy did a firmware update on January 9th, 2024 and it stopped charging the camera. On a whim I switched in settings to “battery” and it started charging again. If I switch it back to solar panel it stops charging. Seems to have fixed the issue leaving it on the battery setting.

This is the solution, I just recently bought mine and I thought the solar panel was faulty or I had not connected it correctly. I set it to solar as per the manual and no charging. Then I tried switching it to battery and it has started charging.
I wonder if Eufy can update the firmware on the next release so the charging is working the correct way around.