Smart lock touch and wi-fi troubleshooting

Hi all!
Hoping someone can help me out.

I recently bought a smart touch and wi-do lock, but have had trouble setting it up.

The first time I tried everything seemed to be going fine (although fingerprint scan didn’t work), and I was waiting to finish the firmware update.

After 15 minutes the firmware update failed but the lock was still added to the App?? (in hindsight I think the lock was out of power). Since I the lock was offline and I couldn’t figure out how to set it up, I tried deleting and repairing it.

Now I cannot get my lock to power on at all (either through the sync button or reset button). I charged the battery to full power and cannot understand why it is not working.

I’ve also tried charging through the micro USB next to the reset button, but this appears faulty since the micro usb will not enter the full way.

Support functions haven’t helped much (and there’s no number to call for my country). Someone please help me out, I’d really appreciate it! :sweat_smile::sweat_smile::sweat_smile:

Having the same issue. Any help?