RTSP not working (very long)

I have several Eufy cameras and 1 of them supports RTSP.
Now I have imported this into Home Assistant via RTSP with generic camera and with WebRTC and that works, but it does not work for very long.
After a while, which is quite short, there is no longer a connection and you get a message like “mse streams wrong response on describe” or “not available”

I searched the internet and this forum but couldn’t find an answer that solved it.
I now know that when I turn off RTSP on my camera in the Eufy app and then turn it back on, the connection works again via RTSP.

It therefore appears to be a problem with the camera (firmware).

Eufycam 2c pro

I hope Eufy will look into this and solve the issue.


If you have any of the battery cams, Eufys send an app messsage after 5 mins that the connection will be dropped to save battery life unless you choose to continue. Since you are using RTSP, you cannot see the message or respond to it and the RTSP connection drops. You have to re-enable RTSP to get the connection restored.

Its been posted about many times on this forum and Reddit in the past and Eufy won’t fix it because they don’t want to reduce battery life.

I understand that when it comes to saving battery power, but there should always be an option in the app to always leave it open.
Nowadays many people have a solar panel connected to a camera hub battery or it is always connected to the power.
In my case, the camera charges automatically when the battery drops below 10%.

I immediately wonder how it is possible that when I open my cameras in Google Home, they always display live images?