P2P Connect issue

I have just purchased a Video Doorbell 2K HD and set up. After a few hours I cannot get live view to connect due to a P2P connection error. I can see this was an issue a few years ago. Has it started again for anyone. I am able to see events and get alerts. No luck over wifi or 4g.

1 Like

Here are some steps you can try:

  1. Check Network Connection: Ensure that your Wi-Fi network is stable and working correctly. You can try connecting other devices to the same network to verify its functionality.
  2. Restart Device: Sometimes, a simple restart can resolve connectivity issues. Try restarting your Video Doorbell and your Wi-Fi router to see if it helps.
  3. Update Firmware: Make sure that your Video Doorbell has the latest firmware installed. Check the manufacturer’s website or app for any available updates and install them if necessary.
  4. Reset Settings: If the problem persists, you can try resetting the settings on your Video Doorbell to default and reconfigure it.
  5. Contact Support: If none of the above steps resolve the issue, it’s best to contact the manufacturer’s customer support for further assistance. They can provide personalized troubleshooting steps or arrange for a replacement if needed.

I have the same issue & have tried all steps above plus got a new one but still having the issue

I have the same problem. Nothing has worked. Very frustrating.

Same problem here too, brand new one and still p2p video failures. Not a good start

Same problem here. Worked through all those suggestions things really annoying as completely defeats the point of why I bought the doorbell

Needs to be sorted or it’s being sent back

Same issue, had one that worked for years, now doesn’t and goes offline all the time. Bought a new one, same issues despite trying all fixes. Bizarrely it works perfectly indoors away from front door (useless really). Nothing has changed in our home environment to cause this. Almost as if it is programmed not to work externally