Not getting notifications anymore

My phone suddenly stopped getting notifications and alerts! I checked everything!


Have you checked your security settings for each camera and the homebase? Click on the security tab in the bottom if the app and then click the cog wheel for whichever mode you have set up and make sure notifications are checked

I have the same issue and the security settings are not the issue. They are set to record and push notification.


I don’t seem to be getting notifications consistently at all, and when I do get them there are no events posted in my log, I have push notify on as well as camera recording.

This is really annoying!

1 Like

Any solutions yet? My wife’s phone gets push notifications but I don’t. It’s not settings either because we compared settings.

I’m having the same issue. I’m not getting any push notifications but my wife is getting them on her phone.

1 Like

Same here with the doorbells. My tablet gets notifications and my phone doesn’t.

Anyone notice that iphone/ipad is ok but android is randomly missing notification


If you change your phone, you must first log out of the old phone account … otherwise you will no longer receive notifications on the new phone (log in with the same account). If you want to have notifications on 2 or more phones, you have to invite the new phone with the email, and create a new account with the new email on the web eufy … I went crazy but I understand why

Hi, I think I just solved the problem if you are an android user. Go to Settings > apps > top right corner with the 3 dots/lines > show system apps > look for badgeprovider > open it clear data > restart phone.


What is badge provider? I’ve tried looking for this but can’t find it.

Do you have an android phone? Otherwise the badge provider won’t show up on iphones

I noticed I had this same problem yesterday. This was after missing notifications from the day before. The doorbell captured several videos without notifications being sent. I’m using android phone. Installed this doorbell a week ago. Nothing I could do would resurrect the notifications. I removed and reinstalled the app from the phone, and started getting notifications again. It isn’t guaranteed. This doorbell is a toy. It can’t really be considered reliable. I have a guess “cannot connect to application server” when using the app has something to do with not getting notifications. Seems to me the whole push notification design on this product has got a serious problem.


Mark sure if you are using Android to set a Power Saving Exclusion for the Eufy app. That will stop the power saver from shutting off the background processes of the app that are needed for notifications. This is the biggest cause of non-network related notification issues I have seen.

1 Like

Hi. I’m having this issue as well for more than a week now. It still records video but I just don’t get notifications. I checked everything, phone and the app, all push notifications are on. I also uninstalled and re-installed the app and also reset the homebase but still no notifications. Is there a solution for this? Thanks everyone.

1 Like

I am also having the same issue, the notifications sent to my android are intermittent, but the recordings are showing in the log. The notifications will work for a short time only if I reset my phone. Please can I ask does anyone have a solution for this?

I’m having the same issue here. I have Android (v11), and my 3 cameras and 4 motion sensors won’t send any push notifications. I’ve also followed the 4 advices that are appearing in the Eufy App regarding this problem, with no success. Please help.

Could your phone be in battery saver or do not disturb at the time of the notification?

This option is not on my phone, I am loosing the will to live with this problem 3 calls to Eufy and still no solution to this problem.