No playback option

There is no recordings playback option since app version v2.1.3_713(EU) on huawei tablet or samsung tablet,not much point of having local storage if you can’t play it back,please fix this major issue.
The updated app works ok on a moto g8 mobile.

1 Like

I think you will find that swiping right on the Live label at the bottom of the screen will bring up the Playback controls. I have 3 Samsung tablets and they all work that way. I think they made changes to the controls without considering that people would be using tablets with larger screens.

By the way, the latest version of the app is at 2.2.3_763 and it works that way as well.

I have just tried the updated app and you are absolutely right,swiping right does the trick !
Thanks,you have been more help than eufy “live chat” who never even bothered to reply to my repeated queries,there cameras are great (and I’ve tried dozens of different brands) but customer support is zero.
I use my file explorer to keep backups of all my apps when they are working properly so that I can reinstall a working version when some update wrecks the app.
Thanks again,I would still be waiting on eufy if you had not taken the time to help.

I stumbled on the answer when I noticed the Playback option wasn’t showing on the screen anymore. I think they changed the controls to accomodate different screen layouts, but forgot to put an arrow or some symbol to tell you to swipe across to get the rest of the controls.

I’ve had good response to emails to support. Chat and phone support don’t seem to be able to help for anything but the basic questions. The emails are answered by people with more technical knowledge.

I have had good luck grabbing Android apks for a number of programs from They have keep over a year of updates for Eufy security, so you can roll back if you need to. I use several Android emulators and I don’t like having to get everything from Google. So far, the apks have all functioned fine and matched with what’s available from Google.