No Homekit Secure Recordings or Timeline

Hi. I have the eufy pan&tilt since a few days. I have set it up exactly as I had to for the use with apple homekit. Installed via eufy app and added from there to Homekit. I have a 200gb icloud plan and I am logged in to that with the correct ID. However, in the home app I only see the stream. There is no timeline and there are no recordings whatsoever. I have tried everything. Uninstalled, reinstalled, logged out, logged back in, restarted my homekit hub (apple tv and homepod), but no matter what I try, I only see the red dot in the home app that it is recording (I think) and the word “live”. I do not see any timeline and I can look back to any recordings. I did notice that the firmware of my pan&tilt in the eufy app is on while in the homekit app it says I have firmware What is going on?


Homekit firmware version is 2.0.68 not Slightly different but that is in eufy. Try changing the notification settings in homekit for the camera. I had problems on another by saying when nobody was home.

I did. I have tried every one of those settings. Right now it is on “always” and I still get nothing, only the live stream.

I assume you’re getting homekit notifications when it detects motion? Or are you not getting those either. If so maybe HomeKit is filtering all the motion out. What do you have for homekit recording options?

I have the same problem with the same camera and I tried everything as you but nothing solve the problem.
I think that is some software firmware problem .
I am very disappointed because I bought only for the HomeKit security video. I hope that eufy solve this with some software update .

Yes I do get notifications when motion is detected and I do get them from homekit. But when I set it to notify only when a recording is started, I get nothing. My homekit settings are “to stream and to record”

Have you upgraded your ICloud storage? Mine did this until I had sorted that out

Like I said before. I have a 200 gb icloud plan.

I have to confirm it is working for me on the iPhone/iPad Pro… All I did (after several trials) update the latest software, be on iOS 14 beta 2 … Disable the notification on Eufy’s App. Delete the cam on Homekit App, turn off the iPhone, turn it on back, then add the homekit integration again (from Eufy’s App settings)… I almost gave up but After (few hours) secure video works fine except the mic doesn’t appear for me… Hope that helps
PS: Video quality on the Homekit is really terrible comparing to the crispness of Eufy’s App!
It’s STILL Beta though!

Unfortunately you will not get an microphone.

In case anyone was wondering, this issue is still going on. Only 2 of my 5 cameras are showing/recording activity. The other 3 seem to be stuck on streaming. What’s funny is they all used to record just fine. I’ve tried everything to no avail. I believe this is a HomeKit issue, as I’ve seen Logitech owners have the same issues. I’ve scoured the Internet unable to find an answer.

Hi All… I found a solution that worked for me and maybe for you if you have a similar setup. So we have a mesh network (Eero) and, at least for us, that was the core of the issue.

Mesh networks broadcast in 2.4 ghZ and 5 ghZ in one combined signal. Your Eufy cam wants to connect at 2.4 ghz. And, to use Homekit Secure Video, it wants whatever hub device you’re using to connect at 2.4 ghz too. So, if you have an Apple TV or Homepod, etc., the Eufy will use that to be remotely accessible in your Home app. But it can only do HKSV if those hub devices are also running on 2.4 ghz.

This creates a dilemma, or so I thought, because who wants to try to stream to their TV or Homepod at 2.4 ghz? It’s much slower than 5ghz.

Nonetheless,. I tried testing it to see if it worked.

First, I went into the Eero app and under “Troubleshooting,” I chose the option “My device won’t connect.” That lead me to a “My device is 2.4 ghz only” tab. Which, in kind, gave me the option to have the eero send ONLY a 2.4 ghz signal for the next 10 minutes. I clicked on that.

As soon as the 2.4 ghz stream was the only one running, I rebooted the Apple TV. It was indeed running slow once it connected (I ran the Speedtest app). I also restarted the Eufy camera.

At first, it seemed to do no good. I was ready to give up. But about an hour later, I looked in the Home app and there were the recordings that had been uploaded to iCloud via HKSV.

Even better, though the Eero network had reverted to the blended 2.4/5 ghz signal… and the Apple TV had gone back to it’s high speed streaming… the Eufy camera remained able to show up in Home with the Homekit Secure Video still working.

TL-DR: The key here is to temporarily turn off 5 ghz signal from your mesh network. During that time, reboot the Apple device that will serve as a hug (Apple TV or Homepod) and reboot the Eufy camera. See if it doesn’t show up as successfully using HKSV within the hour, even after you’ve restored (or let the mesh network restore) a 2.4 ghz/5gh stream.

1 Like

So HKSV was working fine, and has now stopped all of a sudden… after my update to Apple TVOS 15- this is all that has changed…

Signing out of iCloud on the Apple TV and back in has resolved my issue!!

Hi eufy2619… I was trying to remember what we did when we first set the camera up, to get the Homekit Secure Video timeline going. And — much appreciated — your description helped jog my memory.

This is our same setup, right down to the eero and the setting to suspend the 5ghZ (I think it pauses it for 15 minutes). We had to do the same when setting up the eero to work with various smart plugs.

And yes, in our experience, when the 5ghZ pause timer is done, the hubs (an Apple TV and a Homepod) go back to. using the faster signal, while still working with the now-setup devices.

We found that our Eufy camera’s Home recording stopped right after the most recent Eufy update (if it’s useful to anyone, we have the indoor pan and tilt model). It’s hard to say for sure that’s the cause, as it happened almost exactly around the time that Apple put out iOS 15. So maybe it was Eufy, maybe it was Apple.

Either way, the Homekit recordings stopped working and all we saw in Home was the “LIVE” button under the camera. I tried your steps yesterday and it didn’t seem to fix it, but maybe I did things in the wrong order or too fast.

So I’m trying it again now… 1) Use the eero app to suspend the 5ghZ (as described by you above, buried in that troubleshooting menu) 2) restart the Apple TV and Homepod so they connect at 2.4ghz 3) restart the eufy camera using the setting in the app (buried at the bottom of the menu that comes up after selecting the camera from “My Devices.”

And then we’ll wait… I remember, as you said above too, that it took an hour or two before the Homekit Secure Video timeline showed up with a few recordings. So don’t despair if it doesn’t work immediately.

Thanks again, eufy2619, for your original post!

I’m very grateful for the first posts in this thread, as it helped us set up our camera before. I came back because we were having problems again (had to reset the camera 'cause our son accidentally set it up with his iPhone as admin, rather than mine). Finally worked out a fix and I wanted to share it here in case it helps anyone else…

When trying to set up the camera again, we got “Accessory Not Found” for HomeKit.
Our setup is…

Eufy Indoor Pan & Tilt
Multiple Homepods and Homepod minis and Apple TVs
A Eero mesh network

I took some elaborate steps which fixed it instantly. Though, I’m not sure if all the steps I took are necessary. Just in case, I’m going to include the full fix I used below.
But to start, maybe a shorter one that could be key. I didn’t try this, only thought of it afterward. If this first short one works, please let others know. And here it is…


Delete the camera from HomeKit, if you haven’t already.

Open iOS Settings and in the main menu and enter “Eufy” into the search bar at the top (newbies, you need to pull down in Settings to show the search bar). When it comes up, select “Eufy Security.”

Under the iOS Settings menu for “Eufy Security,” look for the “Home Data” switch and turn it off.
Now reboot your phone. Don’t skip this step.

Go back into the iOS Settings, follow the same step to get back to the Eufy Security list of permissions, and turn “Home Data” back on.

Now try going to the Eufy app and adding the camera by the “HomeKit Portal” menu again.
I’m not sure, but I think this is like throwing out the old permissions and forcing the phone to create new, fresh ones.

Now, here’s the actual FULL process I followed to get our Eufy camera back up and working in HomeKit, complete with Home Secure Video recordings. And the result was instant.


  1. First, I deleted the camera from both the Eufy and Home apps.

1a) I also reset the Eufy camera to factory by holding the setup button for 10 seconds (until it beeped twice).

  1. I went around and unplugged everything that could be a HomeKit hub. So, the Apple TVs, the Homepods, and the minis. I also unplugged the camera and our Eero router.

  2. Once I was sure nothing was online, I went back and plugged in just the Eero router and waited for it to connect again.

  3. The Eero allows you to pause the 5ghz band for 15 minutes, so devices that prefer 2.4ghz – like the Eufy cam – can connect. (If you’re unsure how to do this, see here).

  4. I then plugged in just ONE of our HomeKit hubs – an Apple TV that happens to be near the camera – so I could be sure the Eufy camera would use that one to join Home.

  5. Once that Apple TV was online, I plugged in the camera and when through the regular setup process in the Eufy app, adding the camera back in from scratch. See here.

  6. From here, do NOT hit “HomeKit Portal” yet in the Eufy app. Instead, follow the steps I mentioned earlier for purging “Home Data” settings from your phone.

To repeat them here…

  1. Open iOS Settings and in the main menu and enter “Eufy” into the search bar at the top (newbies, you need to pull down in Settings to show the search bar). When it comes up, select “Eufy Security.”

  2. Under the iOS Settings menu for “Eufy Security,” look for the “Home Data” switch and turn it off.

  3. Now reboot your phone. Don’t skip this step.

  4. Go back into the iOS Settings, follow the same step to get back to the Eufy Security list of permissions, and turn “Home Data” back on.

  5. Now try going to the Eufy app and adding the camera by the “HomeKit Portal” menu again.
    Try that… and let everyone know which one (if either) worked!

Again my fix was instant, with HKSV working right away.

My problem is a little different. No issues setting up the 2C Pro with HomeBase on eero. My iPhone 13 shows Live and recorded video through Apple’s Home app. I do not use the eufy app at all. However, my wife can only see Live on here phone. We are in the all-in Apple family plan. Why wouldn’t she be able to see recordings?