No beeps during alarm delay?

My Eufy system beeps with a countdown when I’m arming the system (leaving delay is set to 15 seconds) but on arriving home, it does not beep, it’s just silent during the alarm delay. Shouldn’t it beep? Every other security system on the planet beeps to warn you have triggered and the alarm will sound.

I hope this is not normal because it’s very easy to forget the alarm is set and then suddenly the siren will sound. Not good.


Where do you expect the beep to come from?
The keypad? That device only beeps when leaving. I wrote to support to see if they can add the beep when you arrive home. Did not get a clear response. If you’re talking about this as well, I ask you to write to them as well. The more voices heard about it, the more likely it will be added.
If it’s about the homebase, in firmware, there is a new setting added called ‘Prompt volume’. This slider controls the beeping volume on the homebase and can be disabled. Maybe this is why the beeps are inaudible.

Yes, I discovered this setting yesterday and indeed this was the issue. However I expect the beeps to also come from the keypad and it’s extremely disappointing that they don’t.

This system is odd because in some respects, it’s remarkably well designed and in others, it’s a complete shambles with very strange decisions. I suspect many of these are battery saving efforts but to be honest, I’d rather have a system that works effectively even if it means I have to charge devices a little more frequently.

I’ll write to support about the keypad not bleeping during alarm delay and see what they say.

I agree with you. I’d rather have the keypad beep in alarm delay than the homebase telling where it is by beeping and allow for power removal by a burglar :confused:
Because in the latter situation, you might as wel permanently disable the alarm.

Very good point. I’m going to point that out to support when they reply (I’ve emailed about the keypad bleep).

1 Like

Did you get a response yet, Twist?

Sorry totally forgot to reply here! I did get a reply and they say the usual stuff about how they listen and will take feedback onboard and yadda yadda yadda however I did manage to prompt them to push out 2FA to UK accounts which it seems they had forgotten to do.

I really hope they make the keypad bleep but I think more people will need to request this first for then to see it as worthwhile.

Just landed here thinking exactly the same thing - would be nice to have the keypad beep on entry rather than the homebase!
Is there any way to disable just this arming/disarming beep?

This should be standard.

I also experience a very big delay with the delay beeping from the homebase when coming home. Most of the time it begins beeping when I’ve already turned it off…

Just got the Eufy alarm system and after going through all the options in the Eufy security app, google sent me here.

I mean, seriously?

It’s been many years since this issue have been voiced and still nothing?

Probably 2 lines of code; "if leave delay OR alarm delay == keypad_beep

If this is a battery issue, from what’s advertised, then just make it togglable in the settings.

This single issue, will make me not recommend this product to anyone else that have kids, or anyone not tech savvy. The home base isn’t even audible from my front door, and putting it closer makes this system a security risk I’m itself.
Like some said before, the home base, that saves all the video footage, should not tell anyone where it is. Facepalm

1 Like

Couldn’t agree more. I have also asked for this, or a chime-like device that can beep (and sound alarm).
Unbelievable this basic feature is missing.
I informed eufy, that I cannot sign up for their monitoring/response service unless this is fixed. No movement.

Same issue here. I contact Eufy and the asked me to send the App log. I don’t no why? It’s a simple question. Does the keypad Beep or not when the alarm is triggered. I asked them again.

I also need this. We are forgetting that the alarm is active. I contacted the Anker support and this is there response.

“You can set a custom mode, such as “Reminder mode”, that beeps periodically to remind you that the alarm is active. To set up a custom mode, please follow these steps: 1. Open the eufySecurity app and go to Settings > Custom > Select Customize mode. 2. Choose the devices you want to include in the custom mode and set the desired settings. 3. Name the custom mode and save it. I hope these solutions help you with your issue. If none of these solutions work, please reply to this email and we’ll work together to find a solution that works for you.”

I Can’t find or get the reminder mode in the App settings. Some one else gets this working? The settings in custom mode are the same as Home or away settings.

Definitely second this. Need a sound to come from the keypads on entry to remind us that the alarm is on and needs to be disarmed!

No keyboard beep is a big problem for me. My children often forget and the alarm starts ringing.

This causes problems for my neighbors !

Seriously Eufy! It can’t be that complicated!

Any news about this mistake? I’m facing the same problem!! Just bought a full system, if I should have known this, I had bought another system