New Eufy Indoor Cam 2K “No Response” in Homekit

I just bought two new Eufy Indoor Cam 2K cameras with the intention of using them in my Apple HomeKit environment. According to the instructions I first added them to Eufy Security app, upgraded the firmware (now then added them to HomeKit by using the HomeKit Portal. It all went smoothly, they got added to HomeKit successfully. But when I look at them in Home they both say “No Response”. They both work perfectly in Eufy Security app.
I tried removing them from HomeKit (multiple times) and adding them again, no change.
I tried removing them from HomeKit and Eufy Security (multiple times) then added them again to both, no change.
I tried resetting them (by pushing on the back button for 10 seconds) then repeating the whole process, no change.
All devices were restarted several times (hub, cameras, iphone).
All Apple devices are running the latest versions of iOS (AppleTV Hub, iPhones, iPads).
I even tried created a different account for Eufy Security with location set to USA, no change.
Am I doing something wrong or are these just not HomeKit compatible?

Not sure if you still need help but I had the same issue as you with 2 brand new 2k indoor pan & tilt cameras. I tried everything as you did but nothing helped.

What ended up working for me is making a new home and adding it there. It’s a pain but you might have to make a new home and add everything back there.


same issue, finally i found out why, we need to put the apple homehub (apple TV or ipad or homepod) and the Eufy camera as the same wifi network.that you all set! done