NAS (RSTP) not working

Did anyone tried to use NAS (RSTP) function? I tried on QNAP device - Surveillance Station, IP Cam Viewer, Security Monitor Pro 6 they all fail. I copied the created link that Eufy Security App did and using device static IP address but I get unknowed error. I just want to find a PC version of Eufy Security App or some other PC software that works on Eufy 2C Cams.

I have 4 cams working fine on RTSP. You have to remember that the cams aren’t recording 24/7 so you have to trigger them when you set up the stream. That’s usually where people get confused.

There are half a dozen threads here and on reddit on using an Android Emulator on PCs and Macs to run the Eufy app. Search is your friend.

I know but can’t find any other program that works on Eufy Cam, I don’t use emulators I use PC software like IP Cam Viewer (View Only) and Security Monitor Pro (Motion Detection Recording) , NAS device tried it but fails, I tried “rtsp://(user):(password)@(Station IP Address)/live0” it doesn’t work, the RTSP is already active on eufySecurity App.