Lost all three of my EufyCam 2 in the Home app after iOS 14 upgrade

So I upgraded my devices to iOS 14 when it was released yesterday, and now in my Home app my three external cameras show No Response. They’re still accessible via the Eufy Security app. How do I reactivate them in the Home app? My indoor pan & tilt Eufy cam is still working fine in the Home app.

UPDATE: So it appears the problem is the HomeBase 2, which is no longer functioning correctly with HomeKit/the Home app. I removed the HomeBase from the Home app and tried to re-add it. It failed. Repeatedly. HomeBase is running the latest software/firmware. Did Eufy not do any testing with the iOS 14 betas??? :frowning:


I have a similar problem … my cameras just show up in HomeKit UI … i have done and re-done all the setting . After that they show up for some seconds and then they disappear from the UI . Helppppo

1 Like

I also had this problem with the outdoor wireless cameras (that connect to hub) before the iOS 14 upgrade. Problem persists after upgrade to ios14. Indoor wired camera has flawless connected to HomeKit consistently since installation.

1 Like

Exact same happened to me. I’ve removed from HomeKit and now it never finds it during HomeKit setup


I have had issues pre-IOS14 as well. Have you tried removing the hub from Homekit and then re-add the hub to homekit doing so from the Homekit app and not trough Eufy app?

did you had the Eufy Hub trough the EufyApp or directly from the Homekit , adding a device ? that’s how you got it to work without a problem ??

I tried this. Hub won’t re-add to HomeKit in the Home app. Rebooted (not reset) the hub but still fails to add to Home. :frowning:

I had the exact same issue with my indoor cams. They just went to no response, but it wasn’t immediate. When I went to add accessory in home app they both showed up which meant the cameras knew they weren’t connected but the home app didn’t. I was able to remove and read without issues although these don’t use the hub… I’ve been in ios14 all summer with my phone but only just updated my Apple TV (HomeKit hub). So maybe something there.

I have this issue, but worse on mine is that I removed the Homebase from the eufy app thinking reinstalling it might fix the issue and now it will not reinstall, it just goes into a “scan barcode on base of Homebase 2” loop, where I scan it, it says it’s failed and asks me to reset the base. Just goes around like that in a loop forever.

I’m now stuck with a Homebase and 4 2c cameras that are basically bricks.

I’ve reached out to tech support who mentioned a firmware beta might fix this but that’s as far as I have got.

If this isn’t fixed ASAP I’m just going to have to return everything as they are no longer working and cannot be used. :frowning:

Really disappointed at the lack of testing that has been done on this.

i had the same issue … and basically i just reseted it in the back with the pin that comes in the box , did it 2 times , and i could had homeBase again … this is indeed very frustrating!!! When is that beta firmware released ?

People who are facing issues, can you try the following:

  • Reset homebase and install homebase and camera’s in Eufy app.
  • Enable Homekit in the Eufy app and check if cameras are added to homekit
  • If cameras keep disappearing in homekit try removing homebase in Homekit app (at bridges section)
  • add new devices and search for homebase again, when succesfull homekit should also be asking to identify the cameras with names, locations and streaming options.
  • check if the cameras stay available in homekit
1 Like


I can’t even get past your first step - it is no longer possible to add the cameras to the Eufy security app. I am just stuck in a “take photo of barcode on base of Homebase 2” loop that just asks me to reset the Homebase every time.

I’m literally stuck with 5 bricks at the moment- 1 Homebase and 4 x cameras that are unusable.


This is a firmware issue that will have to be fixed by Eufy. It shouldn’t have happened - iOS 14 has been in beta for months now.

I also tried resetting the homebase2 and had the endless loop of reset and retry. Fixed that problem by unplugging Homebase2 from power. So Eufysecurity app now functions as it should, but cameras still drop out of HomeKit app.

When you say you unplugged the Homebase from power, was that just for 5 minutes and then you retried? I’ve tried that also but no dice :frowning:

Unplugged it for only a minute or so and it rebooted as a new device. Had reset it multiple times before this.

Just as an update, I’ve had to claim everything back under warranty with eufy. Unsure if there are going to send replacements or refund. I’m hoping any replacements won’t just have the same issue. Everything was working fine until ios14 came out. :disappointed_relieved:

Been 5 days now. New system that doesn’t work, so luckily I can send it back.

Must have seen this 100 times!!!

1 Like

So last week I reset my homebase 2 as well. I kept getting the reset screen again as well. I powered down the device and turned it on again, then I heard ‘welcome to eufy’ and was able to continue. Did you try this?


Thanks for the tip. I’ve tried it all. Resetting, powering down. Pressing the sync button after reset, which I have seen some people do in threads on here.

I just tried your suggestion and nothing. Still asking me to reset.

Thanks for trying though.

1 Like