Losing my mind - cameras stop working

I’m losing my mind here. All I have is a Homebase 2 and two Eufy cams. They have been working (to my knowledge) for over a year no issues.

I go to move one of the camera’s, and once moved i can’t stream from it, so I move it back to the original location. Lets call this CamA. It no longer works in the original location. Weird. I check CamB, it works, so i start troubleshooting CamA. I make sure it’s charged, but can’t get it to work. So I remove and re-add it. It re-adds fine, but will not stream. It says it can’t connect.
So I go through a process of removing and re-adding it about a dozen times, i reset it via a 10 second push, i reset it through the app. I can add it, but it won’t stream.
Sometimes at the end of the re-add, it says it has no WiFi signal, next time it says “great” all in the same location. I try all kinds of things and eventually, one time, it works.

OK great… except now… CamB does not work. WTAF?? So I go through the same process with CamB. And I cannot get it to work. It adds, it syncs, and sometimes it works… once or twice. But give it 10 minutes, and it stops working. I’ve tried waiting hours, it does not fix itself. I can remove it, reset if in the app (so it’s talking) but it will simply NOT stream.

Does anyone have any ideas? I’m about to throw these things in the bin.

Its possible that you have an interfering Wifi source that wasn’t there when you originally set the cameras up. Try switching the 2.4 Ghz channel on your router. The Homebase usually will switch channels when you change the router’s channel. If you have a Wifi app for your phone, try to see what channels are the strongest in your area and avoid switching the router to those channels.

Thanks for the suggestion. I’ve changed the channels of the local AP’s (I run a Unifi mesh) without any apparent change. Funnily enough it’s the camera in the same room as the Basestation that is now the one that fails 100%. The camera with two stone walls between it and the base-station is the most stable, but still fails sometimes.

I don’t think changing channels on your local APs will do anything since Eufy doesn’t utilize those connections.

When you setup the Homebase, it usually looks at the main router channel and picks the same channel. What you need to do is force a change to the channel that the Homebase is using. Not sure of the process to force a change when using mesh devices.

If you use a wifi app, you can tell which channel the Homebase is using by looking at the MAC address. Eufy Homebases all start with 8C:85:80.

Maybe support could tell you the procedure to force the Homebase to change channels when using a mesh setup. I don’t have one to experiment with on my test system.

I found that I couldnt add a camera without connecting the home base to the wifi modem.
Once connected it links and everything is great.
Then I could disconnect the home base from the modem and have all cameras.
Weird eh?

After relocating CamA and experiencing streaming issues, I decided to move it back to its original spot, only to find that it no longer works there either. Curiously, another camera, CamB, works fine in the original location. I’ve gone through extensive troubleshooting—ensuring CamA is charged, removing and re-adding it multiple times for packaging design service, and even performing resets via the app and a 10-second button push.