LEDs staying on and draining battery in 1 day.....3 cameras out of 4

I bought a double pack of 2C’s and one of them worked fine and is still going as well as can be hoped. The other, however, drained 100% of battery in 1 day and didn’t detect anything. I noticed that the LEDs on that device remained permanently on (even in daylight). After jumping through the hoops with eufy support, they sent me a single replacement and they wanted me to send back the defective camera to “analyse this rare issue”.

Needless to say, the replacement did exactly the same. LED IR ring remains on ALL the time and no motion is detected. Battery goes in about a day. Support again tell me about this being an unusual fault but eventually accept there is an issue after being sent multiple photos of the camera IR LEDs being on whilst the app shows that it is turned off.

A third has just arrived and I got excited because when set up, it worked as expected. The LED ring didn’t come on and it even detected me sat in front of it and sent me a notification. Unfortunately, it looks like it then auto updated because a minute or two later, the LEDs lit up and have done ever since.

So…has anybody else had this with theirs? Eufy claim that it is unusual yet 3 out of 4 that I have received have done the same.
One thing that is odd, is that the camera that works shows system v 5.4.3 but the one that is faulty is showing 5.1.8. However, it thinks that it is up to date and won’t move to the same version as the working camera.

Any ideas from anybody would be great before I get ready for the support message tennis match.


This is what I sent them to show the lights coming on even when not detecting motion or even when the camera is supposed to be turned off. The last 3 have done this and they replied tonight about the “unusual issue”. Apparently it has now been past on to a specialist.

I noticed you still have the film attached. Remove the film, then hold now cam “SYNC” button for 10 secs.

Now pair it with the HomeBase and test again.