Latest Android app completely broken when using Bluestacks Android emulator

This is a note I sent to Eufy Support after I downloaded and installed the last application update version 3.1.0_994. It won’t even open when using the Bluestacks Android emulator. If you use Bluestacks, don’t load the latest version unless you want a big white screen and nothing else.

| Eufy Support

Seems your lack of testing has caused yet another problem with application updates. The last app update 3.1.0_994 is completely broken when using the Bluestacks Android emulator. Since many people are forced to use this solution because Eufy has yet to produce an app for Windows desktop, you would think that you would test that solution before pushing an update out. When I installed the latest Eufy app and opened it on the latest version of Bluestacks, I get a completely white screen and nothing else. The app won’t even open. I changed every Bluestacks setting that I could think might have any bearing on the app, but nothing worked.

I have been using the Bluestacks app for almost a year and updating it and the Eufy app regularly when new versions come out. This is the first time that the app completely failed to work.

It looks to me like your rush to push out software for your new devices is making matters worse. I have several tickets outstanding and haven’t seen any effort to fix them. Adding this problem to the others you can’t seem to fix is making me look for another security system vendor.

I am posting the contents of this note on Reddit and the Eufy community as a warning to users using Bluestacks not to install the latest app version. |

Note: A workaround for the issue is roll the Eufy app back to v3.0.0 964. This is the latest version that will work. You can get a number of older versions of the Eufy app on I have been using this site for about a year and haven’t had any spyware or adware when loading android app here. They have recently made it a little harder to navigate so you will look at their ads, but the files are still clean and you can get any of the older versions of the app (or any app they host) going back more than a year.


i have same problem last update breaks app in bluestacks

Glad I came across this post. I am new to Eufy and was wondering how to monitor my devices on my windows PC. Hope they fix this.

any time line on when this will be fixed ?

They assigned it a ticket number, but said they never check compatibility with Bluestacks when a new update is issued, so doesn’t look like they care. That’s even though they don’t produce a Windows app because of the availablity of emulators that run on Windows to run the esisting Eufy Android app. Ticket is 37395941 if you want to chime in to support on this issue.

I have the same issue, so I did not update the app on my other laptop, but still not working on the one that I did update , won’t even open the Eufy security app.
I wish I had read this before I updated the Eufy app on the one laptop in BlueStacks
3.0.0_964 works ok
EDIT I found the APK for v3.0.0_964, loaded it in BlueStacks on my other laptop that is now working , but this is a bunch of bull crap that Eufy doesn’t seem to give a crap:angry:

You should be able to uninstall the Eufy app on the broken laptop and replace it with the older version. That’s what I did on several PCs I have set up with Bluestacks.

I even tried to load several different versions of the Eufy app on the new Bluestacks V5 to see if that would work any better. Anything after V3.0.0 964 fails, the same as on Bluestacks 4.

1 Like

Yeah that’s what I did I deleted the new app that was on there and installed v3.0.0_964,and it works now.
I have three other camera apps that I run in BlueStacks but Eufy is the only one that ever failed like this.
At least I have the APK file for app v3.0.0_964 now and if future updates fail to work I can always put .
v3.0.0_964 back.
I always keep automatic update off

Good new for Bluestacks PC users.

I submitted a ticket to Eufy on 7/13/21 about the fact that their latest app versions completely breaks Bluestacks functionality. There have been 4 updates since then and I tested each one hoping that they fixed the issue. Haven’t heard anything back from them on that ticket and assumed they were ignoring the problem. I had tried changing any of the Bluestacks settings that I thought might help, but no joy.

Today, I was searching the Bluestacks Reddit and found that several Android games were having the same issue. After some digging in the Bluestacks forum, turns out there is an easy fix for the white screen that prevents the app from loading.

If you go into Bluestacks settings, under Engine, and change the Application Binary Interface (ABI) from the default of Auto to ARM, the latest Eufy app versions will now load and work normally. I did a quick check of the latest version of Eufy’s app, v3.3.1_1058(US), and live view and the functions that I tested worked normally. I didn’t do an exhaustive test, but so far, looks like this change makes the app functional again. I’ll dig a little deeper when I have more time.

Note: This fix applies to Bluestacks version 4. I haven’t had time to check the beta V5 yet, but I’ll try to check it later this week.

changing to ARM fixed blueStacks v4.280.0.1022 Eufy app working again.

Another user on Reddit tested the solution on the new version 5 of Bluestacks and it worked there as well. There is a difference in how to change the setting(s) as under the new version, the setting depends on which version ( 32 or 64 bit) you download.

Here is link to the instructions for version 5.

1 Like