Issue with geofence

I’ve been using the eufy camera and doorbell setup now for a week or so and I have set it up to use geofence so that when we are in the zone the system is in ‘At Home’ mode and when we’re out of the zone it should be in ‘Away’ mode. When I’m at home, the system works okay and follows the at home protocol, although I have noticed that sometimes I don’t get notifications of the doorbell until about 20mins after the fact (not helpful!)

However to make matters worse, I have noticed when I check the system when I’m out, the geofence sets itself to Disarmed mode, which means I don’t even get a notification if someone rings the doorbell, or if someone breaks into my garden/house there is no alarm. :man_shrugging:t2: The only way I can get it into Away mode is to manually set it each time I go out. The geofence simply selects disarmed when I’m not local to the zone (which is the least secure option it can choose! :man_facepalming:t2:) I have double checked and reset the options, but again today it’s done the same thing

how can I fix this issue?