How to reconnect a Eufy Floodlight Cam you thought was bricked

This has come up a few times before. I am documenting this here to help anyone else, including me in the future in case I need it.

I recently had to change wireless routers. My Floodlight Cam (the original, not the 2 Pro) would not reconnect. I removed it from the app, thinking it would make a clean reconnection. It took me two days and several dozen attempts to get it to work, but it is now working flawlessly once again. After every failed attempt, I was able to talk to the camera with my phone, my router told me it was connected and had an IP address on my network, but the camera said it could not connect. I could ping the camera, I could portscan it and I could even connect to a built-in Telnet server (but not log in), but it refused to admit that it had joined the network. It probably had a faulty gateway or DNS setting. That’s my guess.

The stuff that is already well-known and official I will mark as MANDATORY, the rest is my experience.

  1. MANDATORY turn off network data on the device you’re using to connect the camera. This is official, and the current version of the app should warn you. I used a backup phone with no SIM card. Or use a tablet with no mobile data, or go into settings and deactive everything except WiFi.
  2. MANDATORY Start with your device connected to the same WiFi you want the camera to join. Don’t know why, but it’s in the documentation. Possibly, this is necessary if you are able to use the QR technique in the app
  3. MANDATORY The camera can only connect to a 2.4GHz network. Some routers that have a 5GHz network as well will try to be clever and move devices to the faster 5GHz signal. Find out if your router does this, and disable it.
  4. Turn the Floodlight Cam off.
  5. You need to purge all traces of it from your network. I don’t know how necessary all this is, but it’s what ultimately worked for me. I think a malfunctioning setting somewhere was being remembered and getting in the way. Try and remove all settings from your router. Reset your router if you need to. I run a separate DNS server on a Raspberry Pi, so I deleted its cache and restarted it. I deleted the camera and any associated settings from the router’s device list. For me, with an Asus RT-AC68U router, this was only possible on the Asus smartphone app, not the web-based interface accessible from a computer. Restart the router.
  6. Reset the camera. Do this by holding down the sync button while you turn power back on. This may need someone else’s help, if there’s a switch you can’t reach. Continue holding down the sync button. Do not let go. The camera will turn on, after many seconds the lights will turn on, then the lights will turn off and the LED will turn red. You may now let go of the Sync button, the camera has been reset. This takes a while, try to be patient and not let go of the button too early.
  7. Begin the pairing process: Phone/Tablet connected to WiFi network, data turned off. Choose “Connect Device” in the app, then let it step you through the process. My camera did not have a QR code on it, so I had to do the longer process. Press sync on camera until the LED flashes white, connect your device to the camera’s WiFi network, select your house WiFi network within the app, enter password.
  8. This is what worked for me. All of it: I tried many variations with different steps omitted, but only this process, in this order, worked for me. The camera was not bricked, it was not somehow banned from ever working again.

I hope this helps someone else.

1 Like

I know this is an old thread, but just wanted to give everyone a heads up that these steps absolutely work! Thought I had a bricked Flood Light Cam but following these steps I had no issues resetting and reconnecting. Thanks Jonathan, you saved me money!

As-of 24 August 2023, this process still works for my original floodlight cam (no QR code on the device)!