HomeKit stopped working

Ok I think this is the last straw. HomeKit integration worked for a while but 2 days ago all cameras (2C) disappeared from HomeKit. I can re-add the cameras from the Eufy app and they will show up in HomeKit them disappear again after a few minutes. I tried removing the hub and re-adding it, same problem. The hub shows up in HomeKit but cameras don’t. I am getting ready to throw away the whole system.

1 Like

Reboot your Homekit hubs, Ive had this issue in the past with other accessories.

Thanks for the suggestion but that didn’t fix it. Rebooted HomeKit hubs and Homebase and same issue persists. It’s definitely a Eufy bug, not Apple’s. The Eufy app shows the little HomeKit icon at the corner of each camera for a few minutes/seconds after adding them to HomeKit. Then the icons disappear, but the HomeKit shows as Enabled for the Homebase. So for some reason, the Eufy software stops the sharing the cameras as HomeKit accessories. I have no hopes of Eufy being able to fix something like this but I’ll try a support call nonetheless.

I’m in the exact situation. Started talking to Eufy support almost 3 weeks ago. My Homekit added cameras are also disappearing after about 1-2 minutes. I have tried so many things from resetting homebase, adding Homebase into Home app instead of Eufy. I have also sent proof of purchase as requested. I’m just thinking it’s an apple/Eufy config issue.

Currently waiting for a response from Eufy as Engineers continue looking into it. Fingers crossed they find a fix.

1 Like

I called Eufy support as well and they said “It’s probably related to a recent patch but we will forward it to our engineers”. No reply so far. I’m glad I’m not the only one with this issue.

FWIW I believe the issue is on the Eufy end for sure. I have many other devices and hubs linked to HomeKit and they are rock solid. The Eufy Homebase itself shows as a linked hub (the hub itself doesn’t disappear) but the cameras are gone soon after you add them. This leads me to believe that the Integration is working on the Apple side, but the Eufy Homebase is buggy.

Please keep me posted if you find a solution.


It’s seems I stumbled on a fix. Unfortunately I did two things and I’m unsure which one actually fixed my issue.

First thing I did was reset to factory default my Apple TV. This acts as my home hub.

Second thing I did was turn off Homekit from an old iPad 2 I had that was accessing Homekit.

Then I added Homekit via Eufy app, adding bridge as per process. Cameras stayed in Homekit for at least 36 hours. But due to heavy use and using so much battery, I’ve now gone back to Eufy app to enable me to snooze cameras as I’m home more these days. So unsure if I’ll go back to Homekit, but was good to se wit in action. Recording access in Homekit was a little slow to view after actual recording.

Hope this helps. But IMHO, it does appear to be more of a HomeKit glitch.

Unfortunately this doesn’t solve my issue. I already tried resetting my Apple TV and re-adding the cameras and they still disappeared. Eufy “Engineers” have not gotten back to me about this issue either.

I have the same issues with my 2C cameras. They dissapear every night from HomeKit. Created a support ticket and got the reply that the engineers are going to look into it. This was on the 13th of june. No response so far.


I am having the same issue, and Eufy support has not yet gotten back to me. Did anyone find a solution to this issue?

today I received a new beta firmware update for cameras and homebase ( Hope this solves the issue… will let you know.

1 Like

unfortunately the new firmware did not resolve the issue. Did anybody else find a solution in order to make Eufycams work correct with Homekit?

Uggh. I just received my cameras today. Updated the Homebase and cameras to the latest firmware. My AppleTV (HomeKit hub) is also running the latest firmware. I’m seeing the same issue. I can go into the Eufy app and disable HomeKit auth for the cameras, save, re-enable, save. They show up in the home app for a minute or so (assigned to Default Room again), then disappear.

Yesterday I also tried by removing the eufy baase in Homekit and later adding it again to homekit (next to disabling and enabling the cameras for homekit in eufy app) but this also resulted in the same behaviour. The cameras keep disappearing in Homekit.

Has anybody tried with IOS 14 beta if this issue maybe is resolved? Might be something on the side of Homekit as well.


cameras received and installed yesterday

  • same trouble, today they disappear or do not respond in homekit. No homekit icon anymore also.
  • another trouble, snapshots can be very dark, then when i can have live video, it becomes lighter. After closing homekit app, then reopen, dark again
  • finally, snapshots are not updated in homekit. Perhaps due to energy savings, but it’s useless to have a camera which can’t update snapshots !! unlesse you open the live video…

Yesterday I updated my Apple TV (Homekit Hub) to IOS 14 public beta and added the Homebase 2 and cameras again. It looks like IOS14 is more stable and is able to keep the cameras available in homekit. Also i received an update from Eufy for homebase ( and cameras (2.6.6) this morning so that might help as well.

I hope this does the trick!

quick update, cameras are still working good after last update in combination with IOS14 beta!

Hello, are your camera still appear in HomeKit ? I have iOS and tvOS 14, latest firmware on the Eufy home Dade and cameras and they keep on disappearing after a few minutes… :frowning:

Yes, the cameras still are working OK. What you might try is removing the hub in Homekit (at bridges section). Then add new devices and look for the bridge again. Then add it to Homekit (all doing so from homekit app) again and it should also ask you to identify the camera’s again with the names, location and streaming options. This way I was able to keep the cameras working.

I have same trouble… with homepod, iOS14, new firmware … and cams on 2.6.7… if i am on local network, cams are ok, but if i leave from local… and i try to show me cams on LTE… cams not reacting…

I had a slightly similar issue with my 2x Eufy2 Pro’s and 1x Eufy2. In my case I could still see the devices but not the live feed. A message was superimposed on the life feed within Homekit saying that I should wait until another user had finished watching. Somewhere else I saw a suggestion that the Eufycams might be getting stuck in a loop with notifications. I turned motion sensing OFF on the eufy app and the live feeds sprang back into life on my apple TV and iPhone.