Homebase speaker constant rapid clicking

I’ve just purchased and installed a Video Doorbell, connected to a Homebase 2. It’s working ok, but the speaker on the base emits a constant clicking sound. It’s low volume, but noticeable. I can also see that the light by the Ethernet socket in the base is continually flashing.

If I restart the Base, then the clicking stops but when the doorbell is rung or detects motion, the clicking starts up again

Any ideas what might be causing this? It doesn’t seem right and I’d like to sort it out.

Sounds Iike it could be due to a bad transformer or one that underpowered so it gets caught in the ringing of the bell.

Thanks for the reply. Could you help me out with the issue of the continually flashing ethernet light?

I plug in the ethernet cable, and the Home Base announces that it is switching to ethernet mode. The green LED next to the ethernet port starts flashing rapidly and doesn’t stop doing that.

By comparison, on my PC, the similar green light is solid, not blinking. Should the green light on the Home Base be blinking like it does, or should it just be solid green?

My homebase 2 blinks reasonably fast as well. The flashing indicates data is transferred, so it’s not really bad.

Thanks - but mine is flashing all the time, even when nothing’s happening. Surely data isn’t being transferred all the time?

Hi Martin,

Not of much help but I have the exact same problem. After I have rebooted the Homebase, it is quiet and the green light is almost constantly on. As soon as there has been activity, I can hear noise on the speaker and a clicking sound. Also the green ethernet light goes haywire. I can only stop this by rebooting the Homebase again. Feels like a firmware fault. Hope Anker can solve this quickly.

@Remko1 - thanks for confirming. Good to know I’m not alone :slight_smile:

Fwiw, I contacted Eufy support and they have agreed to replace the Home Base. If it’s firmware, of course, then it won’t help to have a new device. I’ll report back when I have the replacement, but the more people report it to Anker / Eufy the better … then they might take a look at the firmware.

By the way, the firmware on my device is:
System version
Subsystem version

I have the same (up tp date) firmware. Will contact Eufy support as well. Just got it all delivered so I can still go back the the webshop I bought it from. Curious though what causes it.

@Remko1 - OK, good luck with that, and let’s stay in touch as things progress.

Someone posted the same problem on

Went to the shop and exchanged for a whole new set. Hooked everything up and…

The new set has the same problem. After the Homebase has played a sound, the speaker keeps making a low noise with a clicking sound through it. Only way to stop it, is by rebooting the homebase. It also starts when you select a different chime/sound.

Switching from ethernet to WIFI does not solve the problem.

It really feels like the speaker does not switch off after a sound has been played.

Just to rule out interference, I have taken the homebase away from the house to the end of my garden, played a sound and the noise & clicking starts again.

Hmm - that’s not good. I’m on the point of returning mine (by courier), and should get a replacement at some point after that. But given what you say, I’m not optimistic that it will be any different.

I have an open ticket with Eufy Support, so I’ll drop them a note to say that there are others with the same problem, which might well point to a firmware issue.

Had a response from Eufy Support. I have to contact my supplier as Eufy support only deals with complaints from customers who bought from AnkerDirect.

A shame that it took two people to come to this conclusion after I already told them that I went back to the shop, exchanged the homebase and still experience the same problem.

I did not ask them to exchange the homebase, just asked them to have an engineer to look at this behaviour. Are there any technical Eufy/Anker people on this forum who can and want to help ?

I second that request.

It’s difficult to understand why this fault isn’t more widely reported. OK, the LED is round the back of the base unit, so the constant flickering is hidden from view, but the clicking sound (albeit low volume) is very noticeable and very obviously not right. Either it’s a bad batch of units, or a firmware problem.

My return still hasn’t arrived at its destination, so I’m some days away from receiving the replacement. Meanwhile I’m back using the Ring doorbell that I want to replace. Sad to say that a faulty constantly clicking Eufy home base isn’t going to hasten that.

OK, so I’ve received the replacement Home Base 2. I went through the setup process step by step, documenting the results after each step. I fully expected that the new unit would demonstrate the same fault, rapidly and audibly clicking away to itself so I wanted to be specific about when it started.

So I’m happy to report that (so far) I’m not hearing any clicking from the Home Base. The doorbell itself is now fixed to the wall outside, so we’re up and running. I hope it lasts.

The green light by the ethernet port was initially flashing rapidly and constantly (as on the old unit), but I’ve looked again just now and it seems to have settled down. It flashes occasionally but not as incessantly as before.

I’m not really sure what the green light indicates. It looks like it must be data activity rather than just a connection. If so, maybe the unit is polling the network for events and that’s what causes the occasional flashing. But that’s sheer guesswork.

So I’m hopeful that it’s going to be OK now, but I’ll obviously be monitoring it closely.

Good to hear the replacement is not clicking, Martin!
Based on the statement ‘hope it lasts’, was there something wrong with the doorbell aside from the homebase noise?


… was there something wrong with the doorbell aside from the homebase noise?

Well, not necessarily. The noise was the big issue. The reason for my caution is that it took a while for the clicking to start on the original device. To be fair, I’m now a few days into using the replacement, and it seems OK. Like I say, the green ethernet LED is relatively stable too.

For completeness, I should say that I’ve positioned this Home Base upstairs, cabled into my router. The original unit was downstairs. Using the replacement upstairs was partly an attempt to keep it well away from potential sources of interference. I’m actually happy enough to leave it there rather than bringing it downstairs again.

Actually, my next issue is to resolve what can be a long delay in getting notifications on my Android phone. It took more than 2 minutes this morning to be notified about a doorbell press. I’ll look for similar experience elsewhere on this useful community.

That is good news. Is the speaker completely quiet? With mine the noise and clicking only start after a sound has played. It is quieter now than before but i can still hear it when i pick up the homebase and get nearer. It stops after resetting the homebase. As said before. This is my second homebase. I already had it exchanged so i am a bit reluctant to go through that whole proces again. Could you please check if it makes any noise however tiny after chime or selecting a different chime? Also have you tried in the old locatiin downstairs?

Many thanks!

Will do. So far it’s been completely quiet. As I’ve mentioned, the clicking on the faulty one was low volume but quite noticeable, particularly with the unit on a wooden surface.

Not yet. To be honest, I’m somewhat reluctant to do so, in case it triggers the fault, but I guess in the interests of a full diagnosis I should do. Cabling it to the router would now mean some re-routing of the cable, so I’ll see what I can do.

The clicking was happening on the old device when it was connected via cable or wifi. I’ve not tried wifi on the replacement as yet. It’s close to a cable that was already routed upstairs so I’m using that for now.

As to the other issue of the rapidly flickering ethernet LED, that’s started again. For a while it was relatively static with an occasional flicker but as of yesterday and into today, it’s gone into a frenzy again. I don’t think there’s any network activity but it’s difficult to tell for sure. It’s as if the unit is streaming recordings all the time, but I don’t see that level of activity on the router network stats. Very odd.