Have to Enter Password AND Captcha every time I open app

Why do I have to enter my Password and do a captcha every time I open the Eufy app on my Android phone. I am a new user, only had the system for 3 days, I am the owner, so presume that means I am also an admin, and I have one shared user (my wife) who I setup up as an admin, when she opens the app it logs straight in. Even when I get motion notifications I still have to log in to view them, so if someone is at the door, by the time I enter the password, do the captcha, they are gone. I have tried with 2FA on and off, also with FP on and off, even with finger print on, I never get the option to use it. Not a good experience for at all


There’s another thread on this. Just turn off fingerprint login and the issue should be gone

This did not work for me. 4 months with no issues and now this annoying sign in. Also my motion detection stopped working. Not much help from support so far.

1 Like

Same here. Tryed everything. New install on mobilephone from work. Keeps asking 4 pw.
The instal on my own phone doesnt ask for pw.
Pretty annoying. Hope 4 a fast fix

Same here, had to factory reset my phone today and the app now asks me to log in every time. Really f#$cking annoying

Just installed the app for my mother after telling her how good my system is only to find the same problem that she has to log in and try and read the capcha letters every time she opens the app.
She isn’t impressed.
Is Eufy doing anything about this does anyone know?
Do Eufy even know about it?

1 Like

This issue returned after the fix above, eventually, turning fingerprint on/off again fixed it for me.