Geofencing is completely broken!


So as of a few days ago, the geofencing feature has completely broken.

I have only one phone in the devices list, the app knows when it’s inside or outside the zone and shows this in the devices list.

All settings are correct, location enabled, battery optimisation disabled.

When switching to the geofencing mode, you can see it switch to Away mode but then switch back to Home mode seconds after.

I have tried unplugging the Homebase2 and powering it back up. I have tried a different mobile device, I have tried everything.

Someone please fix this issue before I throw all my Eufy products in the bin and go with another system.


1 Like

Did you contact customer sevice?

I contacted customer service via email.

All I got was questions about basic troubleshooting that I’ve already done.

I’m looking for an actual answer from someone, not a copy and paste response.


So if its known… then fix it? What a terrible customer experience this is!

Do they just not care? Is this deliberate to try and force you to spend another £50 on their alarm keypad?

If being able to switch from Home and Away modes was made easier then I wouldn’t mind as much but its buried deep in the app, so many clicks, just put it on the first page with the list of devices or even better, make a widget.


Completely agree, you’re not alone in your frustration.

I had this feature working perfectly a few months ago whilst it was still in beta. but now it’s a complete mess again. I’d send the system back if I thought I had any chance of a refund.


Quick question do you have a dual sim phone as it looks like you have 2 sets of mobile signal bars on the video recording, I dont know much about dual sim phones do they have 2 settings for location services for each sim if this is the case

On a single sim Samsung s8 I’ve tried it in the UK and the geofencing seems to be working ok for me shows I’m in the zone rather than out of the zone

1 Like

Yes it is a dual SIM phone, but no, there is only one location setting , why would there be two location settings? It’s still only one phone that can only be in one place at a time.

Also, you can clearly see that in the video and in the text i wrote that the app correctly identifies if i am in the zone or not, its not a problem of not knowing my location, it just won’t change to Away mode when i am out of the zone.

1 Like

Hi everyone, so today I had the time to try one final thing… remove the Homebase2 from my account completely and set it up again from scratch.

I really didn’t want to do this as it also removes all the devices attached to it like the doorbell and entry sensors so they also needed setting up again and it wipes the video storage.

After doing this though I was able to set up the geofencing feature from scratch and it seems to be working.

Whilst I’m glad to have this working again, I should not have to take this step in order to fix basic functions.

If anyone from Eufy is looking at this, please add the option to just reset the geofencing settings on the device without having to remove and reset the entire device and the devices associated with it in order to set that feature up fresh without any previous settings causing issues or bugs.

On a lighter note, I would like thank Eufy for adding geofencing to the Indoor Cam 2K and the Pan & Tilt cameras. My entire house can now operate on my location now which is perfect.


Good to hear. I feel like doing the same to my doorbell as it isn’t working very good. Did you reset the device or just remove it from the app?

1 Like

Just press the remove button in the app and it will reset.

I did this to all the devices individually and the Homebase2 last though I think you can just remove the Homebase2 and it will automatically do the same ATO any devices attached to it.

If you’re having troubles I highly advise giving this a shot, it’s a real pain to do but worth it to get everything running correctly.

What issue do you have with the doorbell? Do you have the wired or battery one?

1 Like

Ah I see, I pressed the sync button 10 seconds to reset it.
Using the battery doorbell (wired up with 8va).
Actually, I have several issues:

  • the device seems to lose some of its settings after a while. I never have the LED on when motion is detected. After a while it magically turns back on again. Aside from the LED, I have an original mechanical chime. The doorbell also forgets that setting, as the ding-dong sound is delayed (ding…3sec…dong). So it uses a digital chime setting.
  • the device tends to not see me when I walk up to the door, but does see me doing out the door.
  • sometimes it detects humans outside of the activity zone.
  • when setting the sensitivity to 5, I can forget about detection as it won’t detect me at all.

I’m sure some of the problems, if not all, can be fixed with a firmware update.

1 Like

It has never worked properly.

Eufy support will not admit to this

There is no one on here who will be able to tell you they have it working properly, especially if you have more than one person using the geofencing set up.

Interesting because the OP has already stated that he has it working properly…

1 Like

See above post. Still learning how to use forum

1 Like

I have the battery one and its using battery, its not wired up though I plan to do that soon.

The only issue on that list I had was detecting people outside the zone but I made some slight adjustments to my zone and it seems to be ok now. Try making the zone slightly smaller than you want it, i think there is an overlap outside the edges of the zone that will still detect motion.

1 Like

Exactly as my original post said and my follow up. It was working fine when I first got it, and then stopped when I changed my phone. Now I have removed the Homebase2 from the app and set it up again and its working fine again.

So I am on here saying it does work but there are definitely some major bugs that need to be addressed.

1 Like


Is it just you using the geofencing or do you also have other household friends/family set up to use it.

I think the problem is when there are more than one user of the geofencing in the same security set up.

1 Like

yes i have three family members
and geofecing is not working for them
says the femily member … in geofencing settings

for me is the not working geofencing a reason to choose another product like arlo

I als have this problem. My family members phones won’t show op in the Enabled devices. Unless… when I logon with my account on their phone. This is not something I want, because I don’t want my kids to have admin-rights to the camera’s.

Is somebody already aware of this family sharing and geofencing bug?