Geofencing doesn’t work

I recently purchased a Eufy Indoor Cam Pan&Tilt as my first venture into the camera market. The geofencing is absolutely useless on this device. It doesn’t work. I have my own iPhone and 3 other iPhones registered as enabled devices. They are all ‘In the zone’ yet my wife is miles away in town doing some shopping. I have set the geofence with a small radius. I was hoping to purchase other cameras to position both inside and outside the house but it looks as though it won’t be by this brand or any brand associated with Eufy if this can’t be sorted out. I guess you get what you pay for.


Did you set up the location access correctly?

Yes, I have granted access and set to always.

1 Like

Don’t understand your question are you saying the geofencing won’t set when your wife is outside the zone whilst your other phones are

If the other phones are still at home, your camera will be in Home mode.

Yep all phones must be out of the zone for geofencing to work

The app shows my wife’s phone as being in the zone when she clearly is not in the zone. Apart from that, the other 2 phones now show as unavailable when previously they were in the zone. These 2 phones haven’t been moved all day. I know that all phones must be out of the zone for the camera to switch modes.

I have just switched from Arlo to Eufy think I have made a big mistake I know. arlo had its issues but not on the scale that eufy has,will be returning everything and go back to Arlo at the end of the day you get what you pay for


The problems with Eufy just seem to get bigger and bigger. I think I’ll be uninstalling this camera and do some research before getting a different camera that works.


Having the same issues with two iPhones. Geofencing just doesn’t work at all? Both iPhone can be miles away but it shows in zone, seems to never correctly pickup the GPS location on any device. Never detects when you leave or enter the radius zone. All settings are correct, location always on, etc. The Arlo Geofencing worked flawlessly, really hoping Eufy will address this major feature.


In a way, I’m glad that it’s not just me that’s having this issue. The camera is useless without this sorted out. I don’t want anybody to view the stream whilst a family member is home and we’re sure not going to do it manually every time somebody enters or leaves the home. This camera is bound for the bin.

If you are using HomeKit the native geofencing seems to work fine. Maybe just an issue with eufy app geofence logic.

@khy888 & @M11BML have you guys in contact with ?

I’ve already invested more time than what it’s worth. This should be a basic feature that works. I’m finished with this camera.

Same problem here. All ios devices remain in the zone all the time. Geofencing is useless…

1 Like

@Ice4 Contacted Eufy many times. Feedback was ‘We are aware of this issue, we are trying to fix’ They also stated that it would be fixed by mid this year? Nothings changed, they have only removed the word ‘Beta’ from Geofencing text in settings. I had this function on my Arlo cameras and it worked really well, in my opinion, flawlessly. I had it running in the background, no need to change anything. It changed to schedule when in zone, armed when both iPhone’s departed the zones. The GPS location worked for two iPhones, it was aware of the location of both iPhones very quickly.

1 Like

Still shows as Beta in my geofencing setting but agree with you on Arlo once in three years I had an issue with geofencing not setting only had this system for five days and just seem to be getting issues with it , total waste of money

I agree with you the geofencing radius at it’s smallest is stil to big.
With HomeKit it is working : the area is smaller but still too big.
It should be like in Plan very small to let the camera change its settings as soon as we leave our address.


I have bee using the system for more than 6 months and have 2 devices registered for geofencing and providing all is configured correctly it absolutely does work perfectly.

There is one key ‘gotcha’ though that Eufy don’t seem to detail anywhere that I’ve seen and the majority of people don’t understand. On each registered device the app must always be running (even if in the background) and MUST always have access to the users location. If these two criteria aren’t met then it can’t work. In the case of Apple devices iOS will only allow running third party apps to access location info.


I’m having similar issues on Android. I head out and it arms some of the times, but when I get back, it never disarms. I then have to manually switch modes to stop the onslaught of notifications. I wish I could arm and disarm via my Smartthings setup and not worry about it.