Faulty 2k pan and tilt camera

I was lucky or unlucky enough to win this as a prize.
I installed it LESS THAN A MONTH AGO and the pan and tilt camera has FAILED ALREADY!!!
I contacted Eufy and went through all the options to try and reset and fix the issues but to no avail!
No matter what i tried it would not work!
Just a purple light and it rotated then turned off, then started the same loop of rotating and turning off continuously.
Eufy now say that because I won the camera and didn’t buy it, that they Will not fix or replace it!!!
Instead, they said I can buy a new one and have 20% off!!

I didn’t really want a camera but had thought about the possibility of having one.
But having it there is really handy for checking up on the dog whilst I’m at work.
Now I have fittings in my ceiling and cable running up my wall and no camera!!!
Really, really bad that it hasn’t even lasted a month and all it’s good for is a paperweight or throwing in the bin!!
And Eufy will NOT honour their 12 months warranty!!!
Would really discourage me from recommending these products to anyone else or even just buying another product from this company if this is the type of quality That can be expected!!!
And also if this is how you are treated when their products are faulty due to using cheap components.

Eufy has now got back in contact with me and has stated that their warranty does not cover gifts! (Why I’m not sure because if you have their products surely they should last longer than 12 months!)
However, as a one off they are now going to replace the camera that has gone defective after less than a month.
For that I thank them, but hope this one lasts longer. A LOT LONGER!!!
I somehow managed to get the old one working again and it’s been ok for a while and then the other day it managed to brick itself again!!!
So I decided to install the new one.
I started the process of installing the new one on my phone app and connecting it to the WiFi. Then suddenly, just as it was about to connect it says my password is incorrect please try again. Only i can’t try again because this one has bricked itself too!!! Doing the same loop process over and over again.
Anyways, me being the wise person that I am decided to purchase a more simple camera as maybe this will solve the problems.
I decided to purchase the solo camera without the pan and tilt.
Plugged it in and started the process of installing it on my phone app and connecting to the WiFi.
Guess what happened next folks??? Anyone??
You got it!!! It tells me that my password is incorrect please try again and then Promptly bricked itself again!!!
I am now the proud owner of 3… Yes 3 totally useless cameras!!!
Something must be seriously wrong in the software.
Please sort out this glitch!!!
Tried resetting it but there’s not enough time from when the loop starts to when it ends to be able to hold down the button for long enough!
So frustrated by this glitch!!!
Anyone else had this problem??

I don’t know, man, offering 20% off on a new product seems pretty reasonable to me considering.

Do you have the purchase receipt? Without it, it is impossible for them to know if it is still warrantied and if you really got it as a gift.

And also, the quality and durability of a product is measured by the medium between all products distributed to all customers, so even if your personal experience was not good it doesn’t necessarily mean their product isn’t.

If I were you I’d try to look past the initial frustration and realise that you have some nice options, especially considering you’re now actually interested in owning a camera.

You could ask the person who gifted you the product to make a complaint themselves, or make the company a counter offer–asking for either a bigger discount or the same discount applied to a greater number of items–or just take the offer you currently have and choose another product that fits your needs even better.

Good luck and don’t let this problem get to you!

Hi, it’s all sorted now, they sent a replacement for me in the end.
Just to clarify tho, the camera wasn’t a gift from a person, it was won on a competition on this app.
So it came directly from the company, so they know exactly how long I had had it for.
Also, looking at the community feedback, I don’t seem to be the only one that has suffered with this purple light fault!
So ye, it really does bring me to question the durability of these products and obviously means there is a manufacturing faullt with more than just mine.
Hope you don’t suffer from the same fate!
Thanks for the reply tho. :+1: