Fails to Connect to Server

I purchased the Wired 2k Doorbell with chime and it came in last night. I connect it fire up the app and go through the setup process. Everything works great until it gets to wifi. It asks me to select my wireless network, which I do and it goes for about 2-5 mins just connecting to wifi then I get the error Server Busy.
I continued to get this for over an hour. I have tried disconnecting the camera from the wires and trying again. I have tried uninstalling the iOS app and reinstalling and I finally did a factory reset on the doorbell but nothing works.

How can I correct this and use this doorbell cam?

Having the exact same issue.

Bought a wired 2k doorbell and installed it yesterday. I get Server Busy (6) when trying to set it up.

I can see that it has successfully joined my wifi network (and is transmitting data). The access point is 10 feet away from the doorball. I have tried factory resetting it.

I have probably tried to set it up 30 times in the last 18 hours. What’s going on?

Speed test your internet on Wi-Fi at the point in which you put your doorbell. If it’s not that then it’s a eufy sided issue.

Such as your cellphone. If the speeds adequate and stable it’s good on your end.

I am having the exact same issue, (Server Busy (6) - Error Code). I have contacted their support … hoping to get a response.

Initially i thought i got a bad unit, so i returned the first one and got another one … no luck.

i wish there is way for us to confirm if it is indeed a server issue or not … very very frustrating …

Does Eufy ever reply here? Or are we stuck waiting for someone to get it solved and report back?

Yeah, tried that first.

Waiting on a response…

Ahh, in app they said they are 9-5 PST.

At least support is ¯_(ツ)_/¯

Having same issue with wired 2K doorbell. Tried both WiFi and personal cellular hotspots and get the server busy (6) message. Eufy help!

Having exactly the same issue with installation in Ontario, Canada. Got all the steps until a wifi setup. Got the same message (Eufy Server Busy) multiple times even though my wifi router indicates that the doorbell is connected. Have a strong wifi connection all the way to where the doorbell is at.

I am having the exact same issue!

Ok thats WAY to many people with the same problem… Somethings up!!!

Contacted support and got a response to try and connect it to my cellphones hotspot, which I did, no luck. As far as internet speeds go. I dont think thats the issue

This is the response I got from Customer Service

Just for fun.


I’m seeing issues with my local ISP. I don’t feel they were prepared for the high amount of internet usage. Got my credits coming in off my bill. This could be a first step for some.

But in my area of the US I’m not having server issues. Could be system maintenance. Or the server technician didn’t switch it over before doing the needed maintenance.

Having the same issue. Tried to install yesterday (Friday 7/28) and got the same Server Busy message. Tried again this morning and same issue. It appears others have done everything to try to fix but no magic bullet. Very disappointing to buy a new product and like many others it does not work. Have Arlo cameras for years and never a blip. Eufy out of the gate is not looking good.


Same issue here with Server Busy (6)…Tried on my Iphone hot spot wifi but still does not work either. Today is 08/29/2020.

I have been having same issue for two days. I’m in the U.S. Brand new wired 2k doorbell. Brand new 16V 30VA transformer. Physical install went fine, and the doorbell passes the voltage / diagnostics tests steps. I get to the point in the app where I enter my wifi router credentials (success), and the doorbell MAC address shows up on my router, and per the router there is PLENTY of signal strength. BUT… then the problems begin… the app churns forever and forever. I have tried factory resets of the doorbell multiple times, I have tried delete / reload the app (iPhone) multiple times. Most of the time I get the “Server Busy (6)” / “Your doorbell fails to connect to server…” message, sometimes I never get the Server Busy message after half an hour. I always keep the iPhone nearby to assure the bluetooth connection is kept. I monitor the wifi router to be sure the doorbell/router wifi connection is kept. One or two times I got what I call a “half way success”… I could see that the doorbell began to kinda sorta function (as evidenced by the doorbell activating with motion + an audible click + the red bar illuminating & going dark when the motion stops) but the app NEVER completes the connection stage and the doorbell never shows up in my devices on the Eufy Security app. It just churns & churns & never gets past the connecting screen. Aargh, this is such a waste of time and so tedious. It smells to me like their servers are overloaded or down and nobody on their end is dealing with it. And support is M-F only, what the heck, most people install these things ON THE WEEKEND. This is very unacceptable. … Update Aug 30: Still not working. Determined that EVERYTHING on my end is working. While I am trying to set up the doorbell,after the wifi connection step, my router clearly indicates the doorbell is connected and the doorbell is trying to communicate with something at IP Address . All attempts to communicate with that IP address time out (i.e. pings, traceroutes). Something wrong on the Eufy end of things. This is MORE THAN ENOUGH INFORMATION FOR EUFY TO FIND THE PROBLEM & FIX IT. … Update Aug 31 (Monday): got email reply from Eufy this morning suggesting I disable 2FA. tried it, it worked.

1 Like

Submitted a support request via their email address. Now for the wait… First impression is NOT good.

Update Aug 30: Received generic auto-reply email (yesterday from support)

Update Aug 31 (Monday): got email reply from Eufy this morning suggesting I disable 2FA. tried it, it worked.

Same here. I installed the door bell yesterday on 08/28/20 and would get the “server busy (6)”. I thought the server may have been down for maintenance at the moment I finished installing all of the hardware. Nope. I just tried to reconnect the doorbell to WiFi the next day, but I had to redo the startup process first, because the app lost all of the doorbell info and my WiFi name and password. After all the info was entered, I got the “server busy (6)” three times and now I’m over it. I would like to talk to tech support or anybody at Eufy but will have to wait until Monday. I hope the doorbell connects on that day because if it doesn’t, I will return it and want a refund.


8/30 new system and same error

Hey There, same issue in Germany with 2 indoor cams ‘ WiFi/mobile Hotspot makes no difference.