Eufy Video Doorbell p2p connection failure

This evening i started having issues with my door bell , I am getting motion alerts via the app however when I try to view the clip or connect to live view I get an error.

Unable to connect to video doorbell (P2P Connection failure)…

I have removed the app and reinstalled , but still the same. Restarted Homebase but no change.

When i now go to homebase settings , i get “Faield to request .-23”

1 Like

Got exactly the same issue this evening. Possibly eufy servers having issues?

1 Like

Just noticed something strange , It works fine from Android but shows this error message on IOS

If it works on Android, then it wouldn’t be a Eufy server issue. Is your IOS app the latest version?

I’m getting the same and none of my cameras are connecting with my iPad or iPhone - could it be Apple security update?

I have been dealing with this issue on and off for about 4 months. I thought it could be a Eufy device issue as I have three (3) Eufycam 2C cameras attached to the same Homebase that have worked fine throughout. Doorbell was updated in December and the issue went away. About 2 weeks ago I started getting an error saying that the Doorbell was offline. But it was still recording events and I could view them. Go figure. Then a couple days ago it stopped recording completely. This morning I tried re-syncing the doorbell. Did it 3 times now. It recognizes the doorbell, but I am now getting the P2P Connection Failure message again and it won’t detect or record events. Other cameras are still working fine. VERY frustrating. Finally asked Eufy Tech Support to send new doorbell as I am at my wits end trying to make this one work.

1 Like

Exact the same problems

The same problems too. My second doorbell is working fine.

Solved! The same problem. Switch off 2FA and is works fine. (Accountsettings)

1 Like

Am also getting the same issue and it is saying to contact custom services. And am not sure whom to call as am in Australia and there is no Australian number to contact.

Hi, I have just been installing my doorbell and had this repeated P2P issue. Every-time I clicked the doorbell into place I would get the P2P issue and the doorbell would usually disconnect and I would need to go through the set up again. On one occasion when I installed the doorbell I heard a beep, and identified that the screw head used to secure the mount to my wall actually came into contact with the sync button on the doorbell. I altered the fastners I used and ensured that the countersunk head of the screws were level with the mount (the ones supplied are really poor so threw those straight in the bin). Went through the set up again and the doorbell now works ok (finger crossed) - maybe worth checking/trying if recently installed.

I also switched two factor authentication off.

I’ve narrowed the p2p connection problem down to the wifi channel settings on my router. If my router is set to optimise the channel and use 20, 40 or 80 MHz then the eufy 2K wired doorbell occasionally drops out with the p2p connection error. When I disable wifi channel optimisation and only use 20 MHz then it reconnects instantly.

FWIW, I had the same problem (wired doorbell not connecting anymore), after replacing my router.
I was able to track it down to a setting in my Router (ASUS). The router is able to intercept and answer ntp queries from the internal network (i.e. UDP/123). After turning that off, the doorbell works again.

After escalation, eufy support stated that the wired doorbell utilizes “random UDP ports for P2P connections”. I find it weird, to use a port with a defined protocol and I’m not really sure whether I understand or believe this. But fact is, after turning off ntp interception on the “Administration->System” tab, functionality is restored.

I was also getting the “eufy unable to connect to video doorbell (p2p connection failure)” error attempting to get a live view of the doorbell.
I came across this suggest after trying many others and it actually worked:

If your router is set to optimize the channel and use 20, 40, or 80 MHz, your Eufy 2K wired doorbell may occasionally drop out with a P2P connection error. Try disabling Wi-Fi channel optimization and only using 20 MHz.

My particular router (Netgear R7000p) did provide a similar option in the settings:
Here are the steps I took

  1. I logged into the admin portal (http://192.168.1.1)
  2. clicked on the “Wireless” menu buttom
  3. scrolled to find the 2.4ghz wireless settings and unchecked the " Enable 20/40 MHz Coexistence" box.
    After a restart I was able to connect to the video doorbell live without error.
1 Like

This worked for me. Turned it off and it’s working, thanks!

Hello,

I just purchased the doorbell battery power, 2k installed camera to sync with my home base and I couldn’t see any live footage. I got a pop-up message p2p connection failure. I have tried everything install and install app. Removed device and added device again. My home base said it synced successfully.
While I was in the house I clicked on the live footage with the camera close by me and it worked for twice. Then I quickly put it outside back to my doorbell location and then it stopped worked.
No technician was able to assist me but to tell me to troubleshoot several times.
Does anybody know how to fix this?

1 Like

I have the same issue.

I’ve worked out that the live feed works when:
(a) the camera detects motion and sends a notification to the app which I click; and
(b) when the doorbell button is pressed and sends a notification to the app which I click.

If I want to just view the live feed without a notification being present on the app or without it detecting motion, it does not work. In those cases, the app spends about 5 - 10 seconds saying that it is trying to establish a secure connection, then gives an error message saying that it has failed to establish a p2p connection.

After such an error, if I move in front of the camera or press the doorbell button, I can immediately view the live feed. This indicates it is unlikely to be a connection quality / strength issue and in fact either:
(a) some kind of firmware or software issue; or
(b) something odd like it running an unsecured feed for motion / doorbell ring triggered video feed vs a secured connection for other access to the video feed.

The doorbell is recording the motion and doorbell button push events and they are accessible via the app.

I can’t update the settings on the doorbell using the app. Every time I try, it says it has failed. This includes setting of motion sensitivity, motion zones, etc. The app will however allow updates of settings on the chime.

My set up:

  • Chime (version 3.3.0.1m_0.6, subsystem 0.0.0.4)
  • S210 doorbell (version 3.0.7.1)
  • iPhone 8 plus
  • standard ISP provided wifi router

I’ve tested the wifi signal using the Eufy app and it says ‘solid’ full signal for both chime and s210 doorbell. They are all within 5m of the router and each other.

The tech support are helping me out via email, but have quickly reverted to asking for serial numbers and product details, indicating they are likely going to offer me a replacement if their suggestions do not work.

Their suggestions have been to:

  • check wifi strength (all fine, didn’t fix)
  • reset the chime in the app (done, didn’t fix)
  • reset the doorbell by removing the pairing in the app, charging the doorbell for 2+ hours and then re-pairing it on the app (done, didn’t fix)

Others in and around 2021 have said adjusting wifi settings, limiting it to 20mhz only (rather than allowing 20/40mhz switching), sometimes fixes this issue. I checked my wifi settings and it was already set to 20mhz only. Whilst I was in the wifi settings, I swapped the wifi channel just in case it was a traffic issue - didn’t fix it.

A quick Google search shows massive volumes of posts on this issue in 2021, a dip in such posts, and then a massive surge once again from about March 2024 onward. Judging by that trend, my guess is a firmware or app update has caused this problem.

It does not matter whether my phone is connected to the wifi or using cellular data. The same issue occurs.

Some have suggested turning off 2 factor authentication fixes the issue. Tried it, didn’t work.

I will continue to update you all in the hope of helping others in this situation.

UPDATE - 24 June 2024 - Eufy technicians have stopped responding to me. App showed a firmware update was available for the s210 doorbell. I tried to apply it using the app. The update said it would take about 3 minutes but after 20 minutes it said it failed to apply. The doorbell then stopped working. I unpaired it and then tried to pair it once again, but now it will not pair. Will be contacting Eufy’s complaints team if I don’t hear anything tomorrow and will be looking for a replacement or refund.

2 Likes

Hi Randle, thanks for posting such a detailed issue, you have saved me hours of research. I have just bought an S220 doorbell + Homebase 2 and have the exact same issue. I have not fixed the doorbell in position yet so can confirm 100%, if you request a live feed the app begins “establishing a secure channel” as soon as there is motion in the camera connection is made instantaniously.
I will be contacting Eufy support this afternoon and will feedback any progress made.

I have the identical issue, word for word. Support is sending a replacement but I am not optimistic. Any updates on your end?