Eufy login failed

Hello I’m facing issues with application login failed always

Best to contact support to get this sorted. Email is

1 Like

Is the problem solved for you? I am also not able to login to the app.

You don’t say what app you are using Android or IOS. If Android, you might go into the Application manager and open the Eufy App. Clear out the cache then try to login again. My app works fine after the update, so its probably something to do with your device or your account.

If that doesn’t work contact support.

Thank you for your help. I am using the Android app. I did clear out the cache, but it didn’t work.

Same here. I assumed it was due to the EU server upgrade last night. I’ve contacted support but no reply yet.

I’ve tried reinstalling the app. Still getting “Failed to request”

Hello! I also had today problem with login into android app. Always when I tried I get error " failed to request". Clear cache, reinstall app doesn’t help. After all I’ve restarted my phone and that help, now everything works and I can login. Try to restart yout phone. Question is, why I get this error and problems with login? Hope I help you a little bit.