Eufy HomeBase 3 Not Utilizing 2TB Samsung Evo SSD


I’m having an issue with my new set-up. I set up everything without any issues, and it was very easy to do so, but I noticed the Samsung Evo 2TB SSD drive that is in the 2.5 slot was not being utilised, always showing as 100% free space. I then removed the SSD to see where the recordings were going and noticed that it was using onboard storage, so my question is, am I the only one getting this or is it a bug in the firmware? Also, my Solo Cams S330 are not showing any hard drive status information, only NAS (RTSP); the remaining other cams show a 2TB SSD drive. Please see the screenshots.

My Set-up

HomeBase 3 Info

2TB Samsung Evo SSD

Solo Cam S330

Internal Onboard storage


Strange, have you checked to see if the HomeBases firmware is up to date?

Tried unplugging the HB3 and then back in?

Maybe try toggling the Record to HB3 OFF & ON with one of the cameras.

Hi JD,

Thanks for the reply all firmware on cameras + HB3 are up to date I done all this when i was setting up everything as of right now my suspicion is with the new samsung evo ssd, I took it out to run a hard drive diagnostic test on my PC and it failed to complete it also takes a lot longer than the norm to format a hard drive.
I’m going to send it back for a replacement as it’s new I will update the thread with the outcome once i install the new one.

Hi Bit Tech,
:thinking: wondering if the HB3 had corrupted the HD during the format process?

When you get your new HD format it via your PC first, just to test it out to see if it completes with no errors.
Then do the install procedure for placing it in the HB3 and you’ll have to format it again.

Post back with results. Thanks

Hi JD,

I’m back with an update, as promised. I can confirm that the HB3 did corrupt the Samsung Evo 2TB drive. I had to repair it on my PC, then ran a full diagnostic on the drive to confirm that the drive was not the issue, and it passed all tests and stress tests. So I tried it again formatted on PC, then I had to reformat on the HB3 because the HB3 did not like the PC format, but I had the same outcome; it sees the SSD and shows its formatted, but footage was not saving to it again, so instead of me screwing up my 2TB SSD, I used a brand new Mercury Extreme Pro 480GB SSD, but with a twist, I formatted it on PC, then again on the HB3, then I factory reset the HB3 and set up all the cameras again using the 480GB ssd as the storage, and now footage is being saved to the ssd finally what a long process just to add expansion.

Thanks for the Post back.
It says it can handle up to 16 TB drive.
I know it’s not a plug and play as where they ask you to turn OFF / unplug the HB3 before you install it.

There’s got to be some glitch…
Having to have to do the factory reset so it will record on to it and adding all your cams back… What a pain!

Agreed somethings not right even the S330’s cams do not show the local storage they only show NAS(RTSP) option and no local storage mybe the next HB3 firmware might address the small issues.

hey. similar issue here.
I use 1tb HDD.

des this mean the hub 3 can only use SSD but not HDD?

I only run system with 2 cameras with more to come and its important for me to store locally on the hub rather than on the cameras themselves.

No you can use a regular 2.5 spinning hdd also just format it on a pc then format again on the HB3 if the drive is good it will work.
Note: it will take some time for the drive to show that its being utilised by showing it has gone down to 99%

If the HB3 follows previous Eufy gear, they use EXt4 file system. PCs cannot read this format. NTFS that works on most PCs cannot be read by Eufy gear.

You can pop a new drive in a PC and format as a test of your drive, but then you will have to reset and re-format it so that the drive is readable by the Homebase 3.

If you are using a multiple TB drive with HB3 to save your clips, it will take a long time to see any appreciable change in the capacity of the drive as a normal clip may be only 8-10 MB.