Eufy Cam2 stopped recording after today’s update

Well, an automatic firmware update happened around 4 in the morning and now one my Cameras stopped recording altogether. The last recorded event is from last night, almost 24 hrs ago. I have both my cameras exposed to Homekit and I suspect it has something to do since this malfunctioning had happened before. I had solved it in the past by removing this particular camera from Homekit and then re-add it again. Then it started recording again. But this is clearly the device which is mal functioning. My other camera works just fine and has never had a similar issue.
Coincidentally todays update has to do PRECISELY with Homekit recording. Well, I have performed the old solution of removing/re-adding and it works now. I really hope this new update stops the camera acting up. Only time will tell but Id like to know if other users have encountered similar issues or if it is just me.
Sorry for the long post and thanks in advance for any advice you may have

Update*: it’s recording but notifications ar NOT WORKING. Not on Eufy App nor in Home kit