Can't set up Multi-Bridge

Has anyone gotten Multi-Bridge to work?

I got an E330 and set it up. I can stream just fine from it. This camera should be compatible with Multi-Bridge.

When I go to set up Multi-Bridge, the Eufy app says, “Please check the following camera’s connection and try again later.” … but it doesn’t list any cameras at all.

I’m running the latest app (4.7.2) in iOS. I’ve tried restarting the app, restarting the device, restarting everything. I’ve waited and gone back, and I did a bunch of retries but nothing has gotten it past that error message and empty list.

Is anyone else experiencing this? Has anyone gotten Multi-Bridge to set up and work?

1 Like

What is the version number of your HB3 and E330 devices? This function requires the HB3 version to be at least higher than to support it, and the wifi you set up needs to be in the same subnet as your HB3 (for example, your HB3 is directly connected router)

1 Like

HB3: Version
E330: Version (system), 18137 (subsystem)

Both devices report that they’re running the latest respective versions.

My HB3 is connected to my network via Ethernet. I wasn’t able to get beyond my error message so I couldn’t set the SSID and password for the E330 to use. Yes, the HB3 and E330 will be on the same subnet once I’m able to configure it.

Is the problem because my HB3 is connected using Ethernet and not WiFi? I would hope not, since Ethernet is a faster and more reliable connection (and also recommended by Eufy). But I wonder if the app requires the HB3 to have a stored SSID and password to proceed with the setup…

1 Like seems to be an internal beta version. If it is a beta version, you can directly provide feedback in the beta discussion group, and there should be corresponding engineers to solve it.

1 Like

Thank you. Where is the beta discussion group? I can’t seem to find it.

1 Like

I don’t know where the discussion group is, you can send an email to eufy and ask. Have you tried resetting the mulitbridge wifi password?

1 Like

I can’t get that far with the setup. I confirm that all cameras are installed and connected, and then the app tells me to check the following cameras’ connections but it doesn’t actually list anything. So I never can get beyond that since it claims that no cameras are connected (even though my new E330 is functioning properly).

The reason I want Multi-Bridge is because this new camera will be placed further. Right now I’m testing it indoors before permanently mounting it further away (but near a WiFi access point). I want to make sure Multi-Bridge works before installing; otherwise, I’ll return the camera. It’s too bad because Eufy’s website advertises that it works.

1 Like

As far as I know, this is caused by a BUG. You need to upgrade HB3 to version V3.3.2.5 to solve this problem. If it is convenient, you can send me the SN of HB3 and I will transfer it to someone who specializes in handling this. things staff。

1 Like

I got HB3 v. this morning. Multi-bridge setup got further and found my [2.4GHz] WiFi network but failed to connect and then knocked all my cameras (S330’s & E330) offline. I restarted the HB3 and my S330’s were able to reconnect. The E330 took a few more minutes to reconnect.

I tried it again two more times (per the Eufy instructions) and the exact same thing happened.

My network is set up properly. The HB3 is on the same network and broadcast is enabled. In fact, my Eufy indoor cameras connected to the HB3 over the same network just fine so I know they can communicate on that network.

1 Like

I cant get it to setup either. Just keeps failing. Eufy app version 4.7.2. Homebase 3 firmware version

Mulitbridge seems to have a BUG for HB3 using version V3.3.0.3. You need to restart the E330 or try to rebind it to use it normally.

1 Like

Thanks! Rebinding the camera fixed it.

I responded with details to a similar thread: Cant Setup Multi Bridge - Unifi Network - Queries - Eufy Security Collective