Can't connect Homebase 2 (and no blue light)


Since about 2-3 weeks ago, my 2x eufy wireless 2k doorbell cams and eufycam 2 no longer seem to work properly. The events were still firing, but checking the live feed became slower and slower until it stopped showing live feeds for all devices entirely. I noticed that the app was saying that my local storage was (nearly) full, but because I couldn’t access any of the devices during this state, I couldn’t delete anything.

This meant that i could no longer toggle the devices on/off.

I thought it might be an Android app thing so I just refreshing storage and the cache, to no avail.

Last, I attempted to restarted the eufy Homebase 2. I followed all the steps, but it just says “Unable to add Homebase 2”, and shine the red light comes on during the reboot process, it eventually goes off completely but never turns blue.

Does anyone have an ideas?

Many thanks


If the HomeBase 2 is connected wirelessly to your home network, connect the ethernet cable back to it. Maybe it will help?

Hiya - it has always been connected wired via ethernet. And still is.

Any other ideas?

Double check the ethernet cables,~ pull them out on both ends and then snap them back in.
Try… Logging out of the App ~ triple horizontal bars top left of the App, then tap on your name with email Addy, then log out. After that close the App & log back in and try setting it up.
Good luck.

Hi - thanks for your input.

I have tried, as you suggested, logging out, clearing the app’s data, then restarting the setup process (from factory reset), but the exact same issue persists.

Red light flashes, then goes off completely. No blue light at all.

I haven’t changed any network settings, but maybe the last firmware update has had an impact on my config?

Sounds as though you’re doing everything correctly.
Best to contact support for more troubleshooting.
If you’re still within the one year warranty and they concur it has failed you will get a replacement if not sometimes they will offer a discount on a new one.
Let me know how it works out. Thanks

Was having the same issue via iphone app. Thought the homebase had died. Just cant add it via iphones. Tried on android device and homebase 2 got added even with no blue light working first time.

Also testing homebase wifi connection on iphone app does not work but on android it does. what ever EUFY has done with firmware/ios updates need to sort it out

I have the same problems. I couldn’t connecting to my Unifi network anymore.

I went to my mothers apartment with a complete other network configuration and there I was able to setup the Eufy HomeBase2 with a camera (battery powered).

When I came home again, I could use the system to stream the video’s from my camera but now I still can’t add any other device (e.g. doorbell) or make any changes in the setup for the camera. I get “connection errors like (6) and (-3).

I see the HomeBase2 in my network setup so it’s connected.

I changed the Unifi Gateway DNS to (google) and removed all security “blocking” but it doesn’t work.

Anyone a idea what I need to change ?

Some Unifi systems use a common SSID for both Wifi bands. This can prevent Eufy devices from connecting because its trying on 5Ghz and 2.4 Ghz and getting a fail on 5Ghz. You should be able to turn off the 5Ghz band and see if that changes anything.

If that works, you may be able to set up another 2.4 Ghz only network and use that.

I just bit the bullet and bought a $35 2.4 Ghz router and use it for all my IOT devices.

I had the same issue. Although, I still have no blue light, but I was able to add Homebase 2 to the app after checking my privacy and security settings (iPhone), and finding that the eufy Security app had no permission on my local network. Once I turned it on, it, worked like a charm. I hope that helps.

The multicolor LED that Eufy uses always dies on the blue color first. Its a common issue. Doesn’t effect operation.