Cant access video feed on LTE

I have a eufycam 2 cam setup which works perfectly until you try to access alert or live feeds via LTE. I have tried two different providers and 3 different devices and they all have the same issue. Tired to return to the place I bought it and they blamed my network which is clearly rubbish. Anyone else have this drama or does anyone know who I can speak to about getting my money back. Cheers.

Hey, @Salfield!

Thanks for reaching out.

In this case, please try to :

  • Upgrade the eufy security app to the latest version, and let us know the app version
  • Change the network to a Wifi network and see if it helps

Meanwhile, please email your eufy account and the serial number(Homebase) to

Thank you so much for your patience. Looking forward to getting you taken care of as soon as possible!

G’day. The homebase is on my wifi network and when I did the placement it all came back as great signal strength for both cameras. It works perfectly at home but not at all away from it. App is the latest version I believe. Version is 1.6.7_453.
I have sent numerous emails to support but have heard nothing back outside of one reply about turning data on which it is.

Thank you for your reply.

In this case, please try:

-If you could view the recordings using mobile data
-Please let us know if your router has some Access control and firewall settings? If yes, please turn it off.
-Please let us know if you have opened the VPN on your phone? If yes, please turn it off.

If the issue persists, please try to reset the network settings and restart your phone to see how it works? Here are the steps:setting -> system -> backup & reset -> reset network setting.

For the email that you sent to our support, do you have the ticket number that we can locate your case? If yes, please let me know, we will have the engineer to check it for you.

I’m having the same issue it worked when I first got it but not now

I posted something just now.

Seatch for…
Eufy battery powered doorbell live stream over 4G issues.

Waiting for a response.

Did you ever find a fix for this? Still not able to use LTE connection 90% of the time.

1 Like

Its my phone…Samsung A70. I tried accessing the door bell feed on another phone using the app and 4g over the same provider and it worked ok 100% of the time.

My Samsung had no battery saving settings on, neither was the eufy app put to sleep. No VPN was turned on. If I use my good phone as a hotspot for the Samsung…the Samsung works ok even though I’m really sending / recieneg data over 4G via the other phone.

It must be the app sensitive to local 4g.

I have a IPhone 11 Pro Max and it I’ve tried using VPN and still no luck, the moment I switch to wifi the stream loads instantly.

1 Like

I’m having the same issue! Just exchanged my Eufy battery doorbell because I thought it was the unit. Just set up the new one and still same issue. No access list, VPN, firewall restrictions on router whatsoever. I even reset my router (Spectrum) so its bone stock. And still as soon as I open the Eufy app on 4G LTE it says offline. So frustrating. I did so much research on Eufy and finally decided to purchase it and agh I wanted it to work so bad. Usually I wouldn’t have given a system like this a second chance but cmon Eufy please help me out! Samsung Galaxy Note10+ latest software on everything.

We have the same issue. And nothing they mentioned above work :weary: we might have to return it.

I have the same problem, did you fix it yet

I am having the same problem

Can anyone confirm if they’re using their own modem instead of the ISP provided modem? I’m trying to find out if they turn off the firewall inside their own modem if that helps.

Could you guys test this problem with the previous version of the app?
My issue got solved when downgrading the android app, while support told me to get the device replaced!
The last app update significantly reduced the experience: live feed issues, playing back older videos takes a lot of time compared to the old version.

Try this version: v2.0.0_672

Currently still using IOS app - if I run a VPN through my LTE connection I’m able to connect to make cameras fine. As soon as I get rid of the VPN it struggles to load anything.

Update: my issue seemed to have got resolved over night. I left it running because it was too late to package everything up that night to get ready for return the next day. Well I got up the next morning and tested it out and the doorbell loaded up no problem on wifi and on my LTE. Idk if something got updated that night but ever since I posted this comment, it started working flawlessly. I have since then purchased the door sensors, pin pad, pan and tilt cameras and I couldn’t be happier. I wanted my Eufy system to work sooo bad and it came through! I love the products they’re so high quality without the premium pricing. GREAT JOB EUFY! Will definitely add more to the system soon.

1 Like

I’m also having this very issue when connected to WiFi no dramas can view everything but as soon as it switches to mobile data nothing works!!!

I think it might be the IoT setting might be turned on to block incoming signals. Check your modem/router settings to see if anything is blocking traffic.

Got the same problem and finaly found a solution. Force your mobile phone APN to use Ipv4. By default my LTE force it to Ipv6 and it does not work with eufy app…
Please eufy try to manage it working with IPv6 Also de are in 2020 :wink:

1 Like