Cannot connect or view recordings

Had this doorbell for less than a week and becoming increasingly frustrated with it… This morning I am getting motion alerts via the app however when I try to view the clip or connect to live view I get an error.

Unable to connect to video doorbell (P2P Connection failure)…

I have removed the app and reinstalled , but still the same. Restarted Homebase but no change.

Anyone help please before I pack up and return to Amazon.

1 Like

Same ptoblem. I try to play the video and nothing!

hi @barkworth62 @dastenerson.

We want to help you, when you do receive the connection error when trying to view the live video.

While you are at home on the same wifi or while you are away from home?

Is the homebase wired via ethernet to router or wifi to router?


I have the same problem. From my wifi connection all is ok, but from my lte connection I have a p2p error. My home base in connected on ethernet, not wifi.

Same here, i don’t know for how long since we need to stay at home, but when i disable the WiFi and only have a 4g connection i can’t connect to the doorbell of homebase.

I have the same problem, was working fine, now getting p2p connection error over mobile data. Problem started this afternoon

I am having the same problem. Also since this afternoon. I get a p2p error message. When I op the homebase in the app I see a -23message appearing. I actually just installed it new this morning and everything seemed to be working fine.

Same problem, Restarted the Homebase, butt nothing changed.

Same here. this really has to be fixed now!

Same problem here:( Since afternoon can’t connect with 4G to the camera’s and homebase because of P2P connection…


Also since today > streaming the doorbell to my Google Nest Hub doesn’t work anymore > yesterday it was working all fine and I did not change anything here…

So please a quick fix or I will return the doorbell and buy another brand.

Working again

I am having the same issue. I have reinstalled the app. I have a solid wifi connection. Checked my router settings and nothing out of the ordinary. The doorbell just rings and also rings on the phone. But no way to connect and video videos. I get a message “Unable to connect to Video Doorbell”. Hit Retry. “Establishing secure video channel”… circles… and then same message again. No way to view the video events either.

1 Like


I am having the same problem: “Unable to connect to video doorbell (P2P connection failure)” and then it tries to establish a secure video channel.

Practically, the whole system I bought and set up is useless. I can’t see the video from away and I have restarted/reinstalled and the whole shebang. Nothing changes the behavior.

Please help and advise.

I’m having the same problem when I’m away from home. It’s fine when I’m using the same WiFi at home but useless if I’m trying to view recordings or live viewing away from home.
I keep getting a message to move the homebase nearer to the camera. I’ve tried the homebase in various positions around my front room. Tested the signals between router, homebase and door cam and outdoor cam. All get good strong signal.
Then as soon as I am away from home on my phones data connection nothing.
Pretty rubbish and very frustrating.
If its not solved soon I will be changing brands.

Its not a Homebase to device issue. Your router is probably blocking a port that the Homebase needs to communicate with the app. Can you access your live view from the Eufy web portal? That will test that communication between the internet and the Homebase works.

There are dozens of posts of this same issue here and on Reddit and some users have solved their problems. I would do a search and see if you can find one that fixes your problem.

Thanks for the reply. It works fine when I’m in the house so I doubt the router is blocking the homebase as I can view the cameras.

Router doesn’t usually block local traffic unless using a VLAN but can block external internet traffic. If the app cannot communicate back to your Homebase through the internet then your router settings are the problem.