Battery doorbell - no 'facial' detection

Battery doorbell was working all great until an update last November was pushed out to the doorbell.

Previously, when a person was detected, it would show a small circle with their face next to the video and would say ‘Human’ instead of motion.

Since the update, I now only ever get Motion detections and it never recognises people or faces.

How best can I resolve this?

Can you do a soft reset of the doorbell so I don’t loose all the settings? If so, how?

Hard reset seems like the final option?

Have had the same issue since the update. I’ve tried soft and hard resets with no luck. Hopefully a future update will correct this defect.

1 Like

I’d send an email to and ask about the issue. It may be something they are aware of and working on or they might not be aware of the issue. Support doesn’t monitor this area so contacting them would at least let you know if they are aware and/or have a workaround.

I’ll see if I can contact support.

I did a hard reset yesterday - I had to take the doorbell inside to get it to pair with the homebase. Weirdly, as I walked through the house it recorded the motion and flagged it as a human with the little thumbnail showing a zoomed in image of my face.

But after I connected it up outside it wouldn’t do it and now just says motion irrespective of whether it’s a person or car.

Apparently it is a ‘feature’…

2020.09.01, Battery DB:v2.2.1.6 HomeBase:v2.1.2.2h
Modify AI MD logic: When configuring all motion, change from running ai first and then md to: only md.

They did this so motions would be detected quicker.
Fair enough. But I told them let it do AI immediately after… No response…

So suggest it to them. Maybe they will change it.

That’s really interesting, thank you

Will have a play with the Human Only v All Motions - just frustrating as it was working perfectly fine before!!

Seems to recognise Human on Human only detection, but I don’t want that.

I’m happy for it to detect all motion but for it to tell me whether it was a Human or not! Grrrrr

Tried Eufy support but they have been less than helpful