Apple iOS critical alerts

Is there any plan to apply to Apple to enable ‘critical alerts’ in the Eufy Security app? This would be invaluable as I silence alerts at night, but would like to still allow the Eufy notifications through if a camera is triggered. This would be invaluable and significantly add to the benefit of my system!


Thank you for reaching out.

You have our promise that our engineers would work day and night to improve this product and we are glad to have your support and understanding, which would be a huge encouragement for us to seeking continuous improvement.

We will consider the possibility of future development. Any other concerns we can address in the future, please feel free to contact us.

​Thank you for your support. Have a lovely day.


Any update to this?..

1 Like

I’m also interested in this request. As we’re a few to set “do not disturb” at night, I think this is mandatory to develop on Eufy’s side.

1 Like

Interested in this. Honestly, if this isn’t added, its subpar to other security/alarm systems on the market.

1 Like

I would like iOS critical alerts! Apple offers the capability so why isn’t Eufy using it?


Any updates on this? I’ve just purchased a Eufycam and I really miss the the critical alert feature, since our phones at night are all silenced. Thanks!

Please add this! I recently got my Eufy cameras set up and am really missing this critical feature.

1 Like

Ditto. Eufy can you please advise if this is coming. It’s made the night warnings I was after impossible without getting every other disturbance!

100% agree. Where are we on this?

Please add this, I want this for new Baby 2 Monitor but I need to use DND and I don’t and no one should feel comfortable having a baby monitor where the notifications could be missed.


Critical alerts on iOS are critical. I’m planning to sell my Eufy and give it up for a better security system that can actually alert me properly when someone is at or in my home.

Can someone at Eufy get on this massive issue?
I’m about to do the same thing…

Just found a workaround for this…
Go to settings hit “focus” choose your “sleep” mode and add the “eufy” app to the app list. Voilà!

1 Like