App hangs with white screen after update

The Eufy Security App hangs with a white screen since last update on an Android 9 rooted phone.
Is this a deliberate blocking of the App?
I was sold a working system, and now it’s blocked???
Thanks for your help, and if this is the case, an unblockin update, or the choice to revert to a previous version of the App.

I doubt you’d get much support from a rooted device, as there is no guarantee something else may be affecting things.

If it’s Android, I would suggest you clear your app cache, and try again.
I’m not sure if clearing app storage would reset your setup (although I’d hope that should be tied to your Homebase etc), so would only try that as a last resort.

It’s worked flawlessly for over two years.
Then update and blank white screen.
Deinstallation and reinstallation changed nothing.
Managed to find an apk version from december 2022, deinstalled again and reinstalled, and hey, surprise, it’s working again. Without clearing cache data.
Obviously I won’t allow any more updates from Eufy :frowning:
Not impressed with lack of options in the Eufy App, to me it feels like some guy in a corner writing the code without supervision or guidance. Sad and frustrating.

1 Like

Why would?? eufy care if your phone is rooted or not… And block you from using the app if you’re phone is rooted. What could a rooted phone possibly do to the app?
I’ve read reviews on the Google Play Store mentioning the same issue on rooted phones.

I have no idea what changes have been made to the App to make it hang.
I have seen some posts saying that one cause could be linked to a phone being rooted.
It’s not what the rooted phone is doing to the App, it could be that the app does some checks that fail due to this. Who knows? Who knows and will tell us?
Hence I mention this, in case anyone with actual hard knowledge about the problem reads the post and can help explain.

There is a message fladhed during start

“Eufy app is running in the background”

After a recent update, I can confirm that they are in fact blocking rooted devices. No warning, no UI to inform us why the app won’t start. I will never again buy another Anker product.

I after installing the latest update on my Android 9 rooted phone, I was greeted with a persistent white screen whenever I tried to launch the app. This unexpected problem left me concerned and puzzled, as the app had been working flawlessly before the update. It felt like a deliberate blocking of the app on rooted devices, which was disappointing, as I had invested in the Eufy system with the expectation of a fully functional security solution.