Accessory already added to HomeKit error

So for the past few days I have been trying to add my indoor cam to my HomeKit setup. However, all I get is this error message

I have double and triple checked everything in my home app and I do not see my camera in there at all. Anyone else have this issue?

I am also getting the same thing, I only just purchased my c2 setup for this reason but seems this isnt working. Anyone have any ideas of how to help?

I had a very similar problem with my previous Arlo cameras connected to HomeKit. I had to remove all my Arlo cameras from the Homebase, reset all cameras and Homebase and re-add all cameras then add to HomeKit again, this worked for me, I could see all my cameras. Hope this helps. I have removed all my 2C cameras from HomeKit, the battery drain was terrible.

A little late here, but just had a similar problem with a Eufy indoor camera. Turns out to reset the camera you have to hold the sync button down until you hear two beeps, about 10 seconds. After that I was able to re-add to Eufy and home kit both. I cycled power, but apparently that is not the same as a reset.


Omg! This worked for me! I’ve been scouring Reddit for days trying to find this fix. Thank you!

Same for me. I had to hard-reset the HomeBase before I could pair again with HomeKit.