2.4ghz eufy Security Indoor Cam 2K issues

I’m having issues getting the new eufy Security Indoor Cam 2K setup on my netgear wifi router. Anyone have any tips or tricks to resolve? I have the doorbell, door sensors, 6 wireless cameras and 2 base stations setup and don’t have any issues with those…

The router is dual, 5 and 2.4, both have pw setup to gain access.

When I setup the cam, it either times out in the network setup screen, messes up the internet and kicks other devices off, or completes the setup which then I’m not able to access the live feed.


Sounds like a odd bug. Have you tried to set a specific/different WiFi channel for the 2.4ghz?

Yeah, definitely an odd issue. I moved it from auto to channel 1, 3, 9. No improvements.

Not sure if anyone else ran into this problem : -/

Try and using your phone as WiFi Hotspot to test. If u still have issues then contact support or the place you brought it from

1 Like

It would also be good to let us know what router you actually have incase someone has the same one. Netgear makes allot of routers.

Netgear AC1750 (c6300v2) wifi cable modem router, 802.11 ac dual band. Built in DOCSIS 3.0 cable modem.

Using factory settings.


I had issues when i got my Indoor 2k camera but it was related to getting the the Eufy servers. Do you have anything in your network that filters outgoing traffic?

Eufy had a outage the day I got my camera delivered. I managed to get it connected and then all kinds of issues after that. I thought it might be a problem and i reset the camera. After that i kept getting connection errors to my network during the setup process. So basically a bad error message from the camera.

You may also want to look in the routers config for setting up DHCP reservations and see if the camera is seen by the router. I think they may be a page in the config for connected devices. That may help understand if the router is actually seeing it.

Appreciate the idea, unfortunately it didn’t work. It’s just giving me issues with this one product, I just put a eufy doorbell in just last week… no issues.

I’ll take a look around other threads or might just call them… seems like I tried everything over the past few days. I’m at wits end, hours of playing around with settings.

Appreciate the help!

I’m experiencing the exact same behavior with the Pan & Tilt indoor camera, and have the exact same Netgear modem/router unit.

I’ve tried turning off the 5Ghz network, removing the password to the 2.4Ghz, updated the camera firmware, etc.

The only time I could get the camera to work for a few minutes was when the network had no password. Even then, the issue kept occurring, it just took longer initially.

1 Like

I’m going to try changing the DNS settings for the router itself now.

Oh goodness, hello friend! Did you figure out a solution? I got so frustrated one night I just gave up!

No joy. Changed DNS, also for iPv6, Set up a static IP for the camera, tried enabling a bunch of port forwarding, turned off SIP ALG, and Disabled Port Scan and DOS Protection, nothing…

1 Like

Seems like you had a busy day trying to adjusting your settings too… unfortunately i don’t know what more we can do. I tried calling last week and wasn’t able to get ahold of anyone. They seem only to be working via email. Have you tried calling Eufy too?

Yes, I spoke with a friendly advisor, but being such a new product, he was at a loss. I agreed to try some other steps, and he said that they could replace the camera if necessary. Since you’re seeing the same thing with the same router, I’m thinking there may be a setting or issue with the router itself.

Not sure what else to try. Hope Eufy sees this or is aware of a fix. Otherwise, I’m going to ask to return it. I’m not going to replace a $150 router I just bought 6 months ago that works fine with dozens of other products, including the Eufy doorbell and vacuum.

I got another cam in the mail, same issue. Yeap, agree. Eufy needs to find a solution to this. This is my first issue with them, I’ll have to find sometime to call them. I guess I’ll return?? I appreciate all your comments, I’ll keep you posted if something changes!

1 Like

No developments here. Been busy, but will try to call as well.

1 Like

Did you contact the eufy support: support@eufylife.com

Our engineers can help


I’ll send them an email, thank you

It’s something to do with the camera and this friggin’ router. I was able to test using a different router, updated the firmware, enabled homekit functionality, everything was working perfectly.

As soon as I switched back to the Netgear, same shit started up again.

This blows. The router works fine for everything else, including the video from the eufy doorbell. WTF.

1 Like