WiFi Smart Lock Always Offline

Add me to the list. The lock wad purchased from Amazon 2 weeks ago and installed last week. Worked great for two days and now I’m dealing with the same constant drops. Huge pain same debating whether to keep it based on eufy’s apparent lack of engagement.

I have the same issue. I tried many things and no luck. I am staying away from this company. I was planning to buy their camera system but I am done with them. Good luck to everyone.

My SMART lock (Bluetooth) won’t pair. tried all options, still no luck.

Any ideas??

I just installed brand new eufy smart lock touch wifi… at the end of installation, the app asked me to update firmware… up untill then the installation went smooth…
After the firmware update, the lock didn’t come online… I’ve waited about an hour, checked again, it was still offline…
I tried “removing the lock” from eufy app. and restart all over again, but the “reset” button didn’t work… it seems the lock is dead or something after firmware update…
I am so disappointed… basically wasted time and money on this lock…
I called the customer support, they said it might caused by defective battery… but I doubt it… something is definitely not right with this product… they are going to send replacement… I will write more when the replacement gets here.

The new lock won’t make a difference, the issue is with the past firmware updates. Whatever they’ve done they’ve screwed up the WiFi connections and have yet to remedy the issue. We’re all in the same boat. I recommend taking back the lock and getting one from a different company cause Eufy has failed us for the past few months with no solution.

Had 4 locks working just fine for the past 5 months, updated firmware on each one today and all have been offline since. I pull the battery and put it back in, they go back online for about 2-5 minutes then offline again. Checked my WiFi and made sure it wasn’t any issue with WPA3 or WPA2, doesn’t seem to change anything.
I have a wifi6 router running 802.11ax, and 802.11ac as a fallback, maybe some 802.11N on the network. The update was to firmware version on model T8520’s. Firmware notes state it was supposed to improve wifi, instead now I have zero connection.

Update: 6/25/2021, I did have a space in my ssid so I created a new guest wifi ssid for the locks without a space, they seemed to connect for a little longer. Then that same night (last night) i was notified of a firmware update to I updated all four locks and all four have been online and accessible since. Thank you Eufy devs, we’re back in business.

1 Like

New firmware was pushed out the other day, so far my lock has remained connected for over a day so they might have figured it out. Update that firmware and pray

When did the latest firmware released? I just updated yesterday, but my version is

I just installed my lock yesterday and experiencing this disconnect problem.

1.3.1 was pushed to me on the 16th. If they didn’t push it out in mass you might need to contact support

I upgraded to 1.3.1 firmware, still doesn’t help. Offline just after a couple of minutes.

I got the new firmware and am still having the same wifi issues. If the wifi stays on its fine, but if the wifi goes offline it won’t reconnect. Tried doing a remove and re-add but that didn’t work.

I’m having this issue as well. For those that also are having the issue, does your SSID include spaces? Mine does and I’ve read that that sometimes causes issues with devices.

Currently, it will stay connected for about 5 minutes and then go offline. If I touch the device (unlock/lock) or use the fingerprint or pin, it “wakes up” and then I can access it via Wifi for a little bit. Otherwise, I can only get to it via Bluetooth. Seems like a low-power mode or something like that causing the problems.

I’ve opened a support case as well and am waiting for a response.

Eufy support noticed me today that another firmware will be released in 5-7 days. Hopefully, that will solve the problem.

Any luck? They replaced mine due to the same issue up til firmware I have yet to upgrade the new one, on because it works. However, I had to recharge the batter after just 1month.

I’m happy to see it’s not just me! I’ve been pulling my hair out trying to figure this out thinking it was something to do with my WIFI/DNS. Sad that everyone here is having this issue.

I have to factory reset mine to get it responding via the app when not in range of the Bluetooth, restarting the router/WIFI/lock itself only triggers another “Offline - Front Door” notification on my phone.

After a factory reset it will work for a few hours at least, sometimes a day or 2 before it goes offline again.
I can see the Lock is connected to my WIFI and I am able to ping the device so it’s definitely connected to the internet. The problem must be with Eufy

I’m having the same issue…

I reset my wifi and it worked for a couple days. Now it’s showing offline and I can’t reconnect it again. Such a shame because I’ve had such good experiences with Anker products before.

It’s August now. Just got this lock. Upgraded to and wifi keeps disconnecting after 10 min. Will need to return the lock as all the “smart” features are essentially unusable. One odd factoid. The MAC address of the lock that shows on my wireless AP is off by one digit when compared to the the address that is reported in the app.

I’m afraid am experiencing the same exact issue with my 2 recently purchased locks. Inadvertently, I left one of the locks at an older 1.2.x firmware while only upgrading one to 1.3.x. Since I had just moved into my new home a week ago, I wasn’t keeping track of what lock was online or offline. Yesterday, I had time to play with the Eufy app and noticed the 1.3.x lock was always offline but the lock with the 1.2.x firmware was solid. I was planning on calling Eufy for assistance but after reading this thread, it might not be worth my time. My SSID has no spaces and my APs are all new Unifi Wifi 6 Lites. Lastly, I too noticed that the MAC address shown in the Eufy app does not match what is being presented to my AP (the last octet is different). Strange. I’m brand new to this forum, but I’m going to assume that Eufy doesn’t have any ambassadors that visit the forum to chime in. I really like this lock, but this thread has sorta burst my bubble :frowning:

I purchased and installed the Smart Lock, installation went smooth. I noticed the offline issue the next day. I run an Ubiquity UDM Pro router with an Ubiquity AP-Pro. I setup sometime ago, an IoT Wifi Vlan, but the 2.4 and 5ghz bands were joined. Meaning that the router will assign the 2.4 or 5 ghz frequency to any of my IoT devices , depending on different parameters. Since I know that smart devices have issues with the 5ghz, I decided to configure my AP and assign ONLY the 2.4ghz to my smart devices and voila, the lock has been working since. I advise that if you have a router that put together the 2.4 and 5 ghz, configure the router to have them in a separate configurations, then configure the 2.4 ghz wifi to your lock. Cheers

1 Like

I use tp-link Omada eap245 and had my IOT WiFi running only on 2.4 gHz. The problem is still there.