WiFi Smart Lock Always Offline

My WiFi Smart Lock always says “Offline”. When I reset my the WiFi it works for a few seconds, but then quits. Batteries are charged and fine. I connect via Bluetooth fine. Everything works but the WiFi won’t stay online. I cannot change any of my settings or add users unless I constantly reset the WiFi password in the Eufy app. Any help would be much appreciated.


I’ve had the same problem except I’m not able to reconnect by Bluetooth. It happened after the latest update for me. I tried disconnecting, removing device, reset, fully charged battery, but now I’m not even able to add the device back.

1 Like

I’m having the same issue. I just installed the lock yesterday and installed the available firmware update which I believe to be the cause as the lock initially connected to WiFi perfectly. I’m still able to connect/control the lock via Bluetooth and found if I “change network” and enter my WiFI password again for the same network, it’ll reconnect and work fine for a short time before disconnecting again. Seems the lock is losing its WiFi settings somehow.

Same issue here with a brand new Wifi Touch lock. Will give it a couple days to see if it’s just related to an app bug as suggested above, then it goes back if not.

This is my 2nd lock, after exchanging the first one because of some weirdness with the lock/unlock chimes (which this replacement also has; guess I will make a separate post about that!).

1 Like

I would hate to return mine, as I’m very pleased with it otherwise. Let’s hope they get this fixed quickly, I really don’t like having to reconnect my lock to WiFi every few hours!

I installed my Wi-Fi Smart Lock about a week ago. I’m experiencing the same issue. I can connect to the lock with Bluetooth only if I’m within a few feet of it. It will not stay connected to Wi-Fi at all.

My issue seems to have been with my wi-fi. I had a few other devices with glitches but after resetting the wi-fi, everything including my lock have been working fine for the past few days.

This is very disheartening to hear. The only reason I forked out the money for this wifi-built-in device is because I needed it to be reliable remotely. This lock is 180 miles away from me. I cannot go there every couple of days to remind it of anything. And I’ve already been through 3 Yale Locks with external wifi bridges that were just as unreliable. And it isn’t the 3-node mesh WIFI. There are smart doorbells and smart thermostats and smart hubs that use the WIFI just fine. But not this lock!

This lock has only been installed and properly operational for 2 days! Now it is offline and incommunicado? This is absolutely ridiculous!

Why would manufacturers even consider the idea that these things will largely be installed at your primary residence and you can easily take care of these shortcomings? The whole purpose and draw is to be able to control the lock/access remotely!

Rant over…but the problem, apparently, is not.


1 Like

I have two locks, and both have worked flawlessly for weeks and both seem to have developed this issue at the same time- it has to be an app bug; has anyone called support yet?

I installed the lock today. it is a brand new touch and wifi lock. I had the same “Offline” issue. I googled and then I got here…
Hopefully, it’s just an App bug. Hope they could fix this soon.

Got 2 and having the same exact issue since day one. Reported and they sent out a new update last week (4/2021 update ) and it got worse (stay connected just a few minutes then drop)

I heard you and pissed about my 2 defected Eufy smart locks as well. As I told their customer support, my other smart devices are working fine, just thise 2 Eufy touch locks are bad. I even switched to another Mesh but the issue didn’t go away

So as I mentioned, got 2 smart touch and got same exact offline issue. Just received one of the replacement yesterday and it was connected all night (yes, no auto drop). Then I rebooted my router early in the morning (my daily routine) and noticed the new lock remained offline even after the wifi was up for hours. This lock is not smart folks, unlike other smart devices (ring doorbell, ecobee, smart security cameras, etc), not only it couldn’t reconnect itself but we have to be physically inside the home to reconnect it.

Just bought 3 WiFi smart locks and all 3 have connection issues. Fail to connect to blue tooth and can’t use any of the functions.

1 Like

I got the offline issue where it couldn’t auto connect to my wifi but bluetooth is working fine. You have to enable both bluetooth and the location or otherwise it is not going to connect…

I’ve been fighting this issue for well over a month. They’ve replaced the lock and have issued 2 firmware updates, newest was Friday I blieve. Anyone make any headway on this. This is utterly ridiculous to have a “smart” lock that cannot stay connected to the internet. Customer Service seems to have no clue on a solution aside from “please wait for the next firmware update”. At this point I just want them to refund me the money or buy me a comparable smart lock from a different company.

I’m having this same issue. After being prompted to update the firmware, device appeared Offline. I removed it and have been trying to add it via Bluetooth with no success. I guess time to return this POS!

Very unfortunately, I am joining this family with similar issue. Brand new lock, wifi bridge can not connect to internet and device can not be added.

Add me to the list of users with the same issue. I thought I was going crazy or had a defective item…

Either way I sent an email to support. In for at least an email back saying they’re looking into it or something.

I have had mine for 3 weeks and it keeps going offline… supports only response is we can give you a new one or refund your money. They have no interest in fixing the problem. This will be my 3rd new lock that I have little confidence will work.